Spread Windows Forms Spread Designer Guide

Spread Designer Guide

This guide provides introductory task and user interface descriptions of the Spread Designer for
developers using Spread Windows Forms. It describes how to quickly customize a Spread
component using the graphical user interface of the Spread Designer.

¢ Introduction to Spread Designer

e Spread Designer User Interface

¢ Spread Designer Dialogs

e Spread Designer Editors

¢ Designing in the Data Area

e Working with the Design

¢ Designing Shapes
For a complete list of documentation, refer to the Spread Windows Forms
Documentation (on-line documentation).

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide

1 Table of Contents

Spread Designer Guide
1.  Table of Contents
Introduction
Overview of Spread Designer Features
Starting Spread Designer
Getting Started Designing
Simple Example Using Spread Designer
Running Spread Designer Stand Alone
Understanding the Built-in Shapes
Spread Designer User Interface
Spread Designer Menus
File Menu
Home Menu
Insert Menu
Page Layout Menu
Data Menu
View Menu
Settings Menu
Help Menu
Sheet Context Menu
Table Context Menu

Spread Designer Toolbars

Copyright © GrapecCity, inc. All rights reserved.

9-11
11-12
12-13
14-15

15
15-18
18-19
19-22

22
22-23

23
23-25

25

25
25-29

29



Spread Windows Forms Spread Designer Guide 2

General Toolbar 29
Cell Types Toolbar 29
Formatting Toolbar 30
Formula Bar 30
Drawing Toolbar 30
Spread Designer Data Area 30-31
Spread Designer Property Window 31-32
Spread Designer Status Bar 32-33
Spread Designer Dialogs 34
Cell Type Dialog 34-37
Barcode Tab 37-38
Button Tab 38-39
Check Box Tab 39-40
Color Picker Tab 40-41
Combo Box Tab 41-42
Currency Tab 42-43
DateTime Tab 43-44
General Tab 44-45
Background Tab 45-46
GcDateTime Tab 46-47
GcTextBox Tab 47-48
Hyperlink Tab 48-49
Image Tab 49-50
Label Tab 50-51

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide

List Box Tab
Mask Tab
MultiColumnComboBox Tab
Multiple Option Tab
Number Tab
Percent Tab
Progress Tab
Regular Expression Tab
Rich Text Tab
Slider Tab
Text Tab
Conditional Formatting Dialog
Custom File Options Dialog
Go To Cell Dialog
Name Manager Dialog
Row Height or Column Width Dialog
Row or Column Insert or Delete Dialogs
Shape Properties Dialog
Shape Shadow Properties Dialog
Sheet Settings Dialog
Sheet Print Settings Dialog
Sort Dialog
Spread Settings Dialog
Unhide Specific Row or Column Dialogs

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide 4

Zoom Dialog 78-79
Spread Designer Editors 80
Alternating Row Collection Editor 80-81
Border Editor 81-82
Cells, Columns, and Rows Editor 82-84
DefaultGroupFooter Editor 84-85
Formula Editor 85-86
Focus Indicator Editor 86-87
GroupInfo Collection Editor 87-88
Header Editor 88-90
InputMap Editor 90
Named Style Editor 90-91
SheetSkin Editor 91-92
SheetView Collection Editor 92-93
Shortcut Collection Editor 93-94
SmartPrintRule Collection Editor 04-95
SpreadChart Collection Editor 05-96
SpreadSkin Editor 96-97
TabStrip Editor 97-98
Designing in the Data Area 99
Selecting an Item in the Spread Designer 99-100
Selecting an Individual Cell 100
Selecting the Cells with Data 100-101

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide

Selecting a Contiguous Range of Cells
Selecting a Row of Cells
Selecting a Column of Cells
Selecting a Sheet of Cells
Selecting an Entire FpSpread Component
Setting Properties in Spread Designer
Setting Sheet Properties in Spread Designer
Setting Row Properties in Spread Designer
Setting Column Properties in Spread Designer
Setting Cell Properties in Spread Designer
Setting Table Properties in Spread Designer
Entering a Formula in Spread Designer
Adding and Customizing Sheets
Working with the Design
Applying the Design to the Form
Resetting and Clearing Design Work
Saving and Opening Design Files
Previewing a Sheet in Spread Designer
Printing a Sheet from Spread Designer
Designing Shapes
Understanding the Built-in Shapes
Basic Shapes
Arrow Shapes
Balloon Shapes

Copyright © GrapecCity, inc. All rights reserved.

101-102
102-103
103-104
104-106
106

106
107-108
108-110
110-111
111-113
113-115
115-116
116

117

117
117-118
118

119
110-120
121-122
122-123
123-124
124-125

125



Spread Windows Forms Spread Designer Guide

Special Shapes
Star Shapes
Customizing Particular Shapes
Customizing Text as a Shape
Customizing a Polygon
Customizing a Line as an Arrow
Things to Do with Any Shape
Adding a Shape to a Sheet
Changing the Appearance of a Shape
Rotating a Shape
Resizing a Shape
Moving a Shape
Adding a Drop Shadow
Locking a Shape
Using Keys with Shapes
Advanced Topics for Shapes
Creating a Custom Compound Shape
Using Shapes with Maps
Using Pictures in Shapes
Creating Free-Hand Annotations

2. Index

Copyright © GrapecCity, inc. All rights reserved.

125-127
127-128
128
128-129
129-130
130-133
133
133
133-134
134-135
135-136
136
136
136-137
137
137
137-139
139-140
140
140-141

142-159



Spread Windows Forms Spread Designer Guide

Introduction to Spread Designer

You can quickly design a spreadsheet component using the Spread Designer. Whether you are
prototyping a complete spreadsheet component or simply customizing some aspect of an
existing spreadsheet component, the dedicated graphical interface offers many features to save
time and effort. It also provides a way for you to add data to and set properties for the
component, including properties that are not available at design time in Visual Studio. You can
set both design-time and run-time properties. In most cases you can preview changes before
applying them to the spreadsheet. Once all the changes are made, you apply the changes to the
spreadsheet component on your form. With the Spread Designer, customizations can be made
quickly and easily.

The Spread Designer also allows you to save your work to a file and share that file with others.
You can save your design as a file and open files of previous work or from another team member
from within Spread Designer.

Spread Designer lets you make just about any customization to the spreadsheet component as
well as add shapes to improve the user interface. There are dozens of built-in shapes and the
ability to customize them.

For more details, refer to these introductory topics:

e Overview of Spread Designer Features

¢ Starting Spread Designer

¢ Getting Started Designing

¢ Simple Example Using Spread Designer

¢ Running Spread Designer Stand Alone

¢ Understanding the Built-in Shapes
Then, when you are finished with the introductory material, find the more detailed explanations
in these topics:

¢ Spread Designer User Interface

¢ Designing in the Data Area

¢ Working with the Design

¢ Designing Shapes

Overview of Spread Desigher Features

The Spread Designer offers these advanced features

e Set properties and prototype design with little effort

e For more information, see Spread Designer User Interface.
e Multiple ways of accomplishing a task: menu, toolbar, properties list

e For more information, see Spread Designer User Interface.
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e Multiple toolbars for shortcuts
e For more information, see Spread Designer Toolbars.
e Custom names in formula references
e Recent (Most-recently-used) files list
e For more information, see File Menu.
¢ Add shapes to enhance the appearance
e For more information, see Designing Shapes.
o Ability to preview before applying to sheet
e For more information, see Previewing a Sheet in Spread Designer.
e Ability to save to XML for re-use
e For more information, see Saving and Opening Design Files.
e Ability to print
e For more information, see Printing a Sheet from Spread Designer.

For more information about Spread Designer, return to the Introduction to Spread
Designer.

Starting Spread Designer

You can start Spread Designer from inside your Visual Studio .NET project by doing one of the
following;:

e Right-click on the FpSpread component on your form and choose Spread Designer.

e Select the component on the form, press F4 to display the Properties window, and
select the Spread Designer verb at the bottom of the Properties window.

You can also run Spread Designer outside of Visual Studio .NET as a stand-alone application.
To do so, run the FarPoint.SpreadDesigner.EXE from the product bin folder.

When running Spread Designer in stand alone mode, several options are grayed out and not
available to use. These are options that are available with the version that integrates with Visual
Studio but are not needed when Spread Designer is run as an independent program.

For more information about Spread Designer, return to the Introduction to Spread
Designer.

Getting Started Designing

To begin designing your Spread component in the Spread Designer:

e Set preferences, as described in the Settings Menu.
e Set the Spread settings, as described in the Spread Settings Dialog.
o Set up the sheets and customize the sheet settings, as described in the Sheet
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Settings Dialog.
e Work in the data area of the sheet, as described in Designing in the Data Area.

e Optionally, add shapes to highlight areas of the sheet, as described in Designing
Shapes.

e Save your work to a file, apply the settings to the component on the form, or print a
copy, as described in Working with the Design.

For more information about Spread Designer, return to the Introduction to Spread
Designer.

Simple Example Using Spread Designher

This simple example steps you through creating a spreadsheet in Spread Designer. It creates a
spreadsheet to help with tracking which products in an inventory are selling well. This example can be
used with Spread Designer in stand-alone mode or from inside a development environment such as
Visual Studio.

For more information about Spread Designer, return to the Introduction to Spread Designer.
First, launch the Spread Designer

1. Launch the Spread Designer.
Then setup the spreadsheet.

1. Set the size of the spreadsheet. Click on the sheet corner to select entire sheet. In the property list,
scroll down to Layout. You see that the number of rows and columns are each 500. Click on these
to edit them. Change them each to 10.

2. Edit the headers with meaningful labels. Select a single row by clicking on that row’s header.
Right-click and select the "Headers" verb. The Header Editor is displayed. Change the width
to 60 and click ok. A pop-up appears asking whether or not you would like to apply this to the
entire header section; click Yes.

3. Now right-click on the label "A" for column A. Choose Headers and change the label to "Product”
by typing in the Text property in the property list.

4. Next, change the Background color to yellow in the property list and then click OK and Yes to the
dialog. Then, right-click on the column header again, select column width, and change the width
to 75. Select OK. Click on the label "B" for column B. Using the same steps, change the label to "#
Produced." Change the cell type to number by right-clicking on the selected column and selecting
the CellTypes menu option. Change the width to 75. Click on label "C" for column C. Change the
label to "# Sold." Change the cell type to number and the cell width to 75.

5. Click on label "D" for column D. Change the label to "Price." Change the cell type to currency.
Change the width to 75.

6. Click on label "E" for column E. Change the label to "Income." Change the cell type to currency.
Set the foreground color to blue. Select cells E1 through E4. Then in the formula bar, click =, and
type C1*D1 in the formula text box. Select Apply and OK. Set the "locked" option to true (right-
click on header, select headers, set Locked property in property list). Set the column width to 85.

7. Click on label "F" for column F. Change the label to "Product Status." Change the cell type to
combo box (right-click on selected column, select CellTypes menu, combo cell, and click the
Items tab).
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8. In the Items tab, type "Continue" on the first line and on the second line type "Discontinue."
Click OK. Change the column width to 85. Now, click the label "5" on row 5, and change the row
header text to "Total." Also change the label of row 6 to "Average."

9. Enter the formula SUM(B1:B4) in the cell located at the intersection of the "# produced" column
and the "Total" row. Enter the formula SUM(C1:C4) in the cell at the "# Sold" column and the
"Total" row. Zero values appear in the formula cells. In the cell intersection of the "Total" row and
the column labeled income, enter the formula SUM (E1:E4).

10. Finally, in the cell intersection of the row labeled "Average" and the column labeled income, enter
the formula Average(E1:E4). This gives you your average income. You can see that the number of
items sold changes your average income, something you may not have recognized without the use
of Spread Designer.

Let’s apply the changes.

1. To apply the changes, simply exit Spread Designer, and you are returned to your original
spreadsheet, now completely resembling the application you have just created in Spread Designer.

2. You may now enter data into any of the "# sold" or "# produced" cells, and you see the income
totals change. You may also change the prices to see how that would effect the income.

The next step is building your application.

1. To build your application, click on the build header in the main toolbar, and scroll down to
"Buildfilename."

2. Visual Studio creates an executable file and places it in your Visual Studio projects folder.
Then we can save the file and exit.
1. Click on File and Save in the main tool bar to save your project.

The result of applying the setting to the Spread component from the Designer is that code is put in the
part of the form code as illustrated here.
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Running Spread Designer Stand Alone

You can run Spread Designer as a stand-alone application independent of Visual Studio. For many developers who want
to create and share designs, this is a quick way to design FpSpread-based applications and save them off as either XML
or Excel-compatible files. Practically all of the functionality you expect from the Spread Designer is available in this
stand-alone application except those features that involve applying to and reverting from the form in Visual Studio.

To run the Spread Designer as a stand-alone application, simply run the Spread Designer executable installed in the bin
directory.

You can create a shortcut to the EXE file or work with the Spread Designer application as you would any other
application in Windows.

You can also show the Spread Designer at run time. Add the FpSpreadDesigner component to the form at design time
and use the Show ('Show Method' in the on-line documentation) method in the FpSpreadDesigner class to
display the component at run time.

The items that are not available in the Spread Designer when run as a stand-alone application are grayed out or not
selectable, as shown in this figure.
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If you wish to save your work, be sure to save the design as a file using the Save or Save As option from the File menu
icon.

For more information about Spread Designer, return to the Introduction to Spread Designer.
Understanding the Built-in Shapes

The FpSpread component provides the following built-in shapes that provide a basis for much
of the shape customization that is possible with the component. These shapes are available from
the Insert menu in the Spread Designer as well as from separate classes in code.

The shapes are summarized in this table (with arbitrarily colored examples of the shapes).

¢ Basic Shapes

e Arrow Shapes

e Balloon Shapes

¢ Special Shapes

e Star Shapes
To add a shape, you can use code or you can use the Spread Designer. For more information
about creating shapes in the Spread Designer, refer to the Insert Menu. For more information
about the shapes classes, refer to the FarPoint.Win.Spread.DrawingSpace

('FarPoint.Win.Spread.DrawingSpace Namespace' in the on-line documentation)
namespace.

Each shape can be rotated and resized, and their ability to be rotated and resized by the end
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user can be constrained. Colors, shadows, and transparency can be adjusted.
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Spread Designer User Interface

14

While not a comprehensive summary of every part of the Spread Designer user interface (UI), this
brief overview points out a few of the main parts of the interface and shows you the basic layout of
the Spread Designer. There is more than one way of doing many of the design actions. The goal of
the interface is to allow you to quickly and easily set the appearance of the spreadsheet and

customize the interaction that the user has with the spreadsheet.

The Spread Designer provides the following interface for designing your component.
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The following topics describe some of the parts of the Spread Designer UL

e Spread Designer Menus
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Spread Designer Toolbars (including the Formula Bar)
Spread Designer Data Area

Spread Designer Property Window

Spread Designer Status Bar

For information about the dialog boxes and editors, refer to Spread Designer Dialogs and
Spread Designer Editors.

You can obtain help for using Spread Designer by selecting Help from the Help menu icon, or by
clicking the Help button in some dialogs.

If you are using the Properties list, you can press F1 to obtain the help topic for whichever property
is selected in the list. You can also press F1 while an object is selected, such as a cell, to obtain the
help for that object. For example, if a cell is selected and you press F1, the help displays the Cell class
help topic.

Remember that the Properties list refers to the properties of the overall component, sheet, row or
column, or even individual cell, depending on what is selected. Properties of shapes are edited in
separate dialogs. For more information about shapes, refer to Designing Shapes.

Spread Designer Menus

The Spread Designer provides menus for accessing and saving files, working with properties of
the sheet, and for setting properties for the FpSpread component. Several of the things you can
do from the properties window can also be done from several of the Editors that can be called
from the menus.

¢ File Menu

e Home Menu

e Insert Menu

e Page Layout Menu

e Data Menu

e View Menu

¢ Settings Menu

e Help Menu

¢ Sheet Context Menu
e Table Context Menu

For information on context menus that are available when items in the data area are selected,
refer to Setting Properties in Spread Designer.

File Menu

The File or Spread Button menu (click on the file menu icon) generally has operations, such
as opening or saving a file, and printing. You can also reset the spreadsheet to default settings
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and preview the spreadsheet from this menu. From here, you can apply changes to the
spreadsheet or revert to the settings when it was originally loaded. (For information on
reverting to previous settings, refer to Resetting and Clearing Design Work.) If you select
a text file, an additional dialog appears, the Custom File Options Dialog. (For information
on printing, refer to Printing a Sheet from Spread Designer.)

The following image shows the icon for the File menu.

Q-
\ Home In=ert

File menu icon or
Spread button
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The menu options are explained in the table below.

Menu Description

Option

Open This offers a dialog box for browsing to a file to open. Only XML and XLS files
are valid.

Open This dialog to the right of the Open option offers a drop-down of recently

Recent opened files that can be opened.

Save This saves the file. If the file was previously specified and saved, this simply

saves to that file. If the design has never been saved, the Designer offers a
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Save As

Apply
Apply and
Exit

New

Revert

Preview

Print With
Setup (see
Page
Layout
menu)

Print
Preview

Print

Print PDF

Clear
Recent
Files List
(History
File List)

Exit

Home Menu

dialog box for saving the file with an option for specifying the file type.

This offers a dialog box for saving the file with a new name, or for saving the
file to a new file type.

This applies the changes done in the Spread Designer to the FpSpread
component on the Form in the development environment. If Spread Designer
is run stand-alone, apart from the development environment, these choices are
not available.

This resets all values to their default values and clears the data area of any data.

This reverts the FpSpread component back to the values in the FpSpread
component on the on the Form in the development environment. If Spread
Designer is run stand-alone, apart from the development environment, these
choices are not available.

This opens a separate window with a preview of the FpSpread component. The
data area of the Spread Designer is grayed out and the preview window has
focus.

This opens a printer setup dialog to allow you to change any of the options on

the default printer before printing the appearance of the data area of the
design.

This opens a separate window to allow you to see the design according to how it
prints when sent to the printer.

This does not display a dialog and simply sends the design to the default
printer.

This prints (saves) the file to PDF.

With this preference selected, the list of recent files is cleared and the File
menu adjusts accordingly, removing the Open Recent from its list of choices.

Click on the Exit button to exit the designer and return to the spreadsheet.

Copyright © GrapecCity, inc. All rights reserved.
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The Home (or edit) menu allows you to perform standard Clipboard operations (such as cut, copy, and paste) and
various selecting and navigation functions. You can also set the font information and cell borders.

The Clipboard section of the Home menu contains the clipboard operations and undo/redo. The Font section
contains the font options as well as the cell border options. The Alignment section contains the text alignment options
and merge options. The CellType section is for creating or clearing cell types. The Style section is for conditional
formatting and the Editing section is for locking, selecting, sorting, or searching cells.

@ s 0=l NET 35 Framewark Ediion] ===
Home Insert Page Layout Data View Settings (7]}
:: E:; Microsoft Sans Se1 ~ 1825 ~ | A A7 = == M S | | LL?% ;J; I(-:T::r;‘dl i
® F'Est; - A-B I b - EE E E g £ £ &5 Mee N‘:l"e E?an:tﬁ;aglv @, SelectAll - &4 Find ~
Clipboard Font [= Alignment CellType Style Editing
The options are explained in the table below.
Option Description
Clipboard These are the Clipboard operations that allow you to cut, copy, and paste data from one selected
Section (Cut,  range of cells to another. If multiple cells are selected that are discontiguous, then only the data in
copy, and the last cell is cut or copied to the Clipboard.
Paste)
Clear This clears the celltype.
Go To This allows you to specify a cell by cell reference in A1 notation (such as G12) and brings that cell into
view.
Alignment This allows you to set the center the text, merge, etc...
Section
CellType This allows you to specify or clear the cell type.
Section
Style Section  This allows you to set conditonal formatting.
Editing This allows you to lock cells, select, sort, or find text.
Section
Editing This allows you to search for text in the contents of cells in the sheet. This option brings up the Find

Section (Find) dialog. For more information on the Find dialog and searching, refer to Allowing the User to
Perform a Standard Search (on-line documentation).

Editing This allows you to select the entire sheet, all the cells in the data area, or only the cells with data.

Section (Select
All)

Insert Menu

The Insert menu can be used to add special characters, shapes, sparklines, tables, camera shapes, or charts. The Text
section contains Symbol and WordArt options. Symbol is used to add special characters such as copyright symbols,
unicode characters, and so on to a cell. WordArt is for creating a shape that has text. The chart section is for adding a
chart control to the Spread control.
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Inserting Shapes and Camera Shapes

The easiest way to design shapes on top of the spreadsheet is to use the Spread Designer Insert menu. The Drawing
Tools menu is displayed after you create a shape using the Insert menu option. The Insert menu option is used to
create various types of shapes and can be used to save, load, or delete a shape. The Insert menu provides a quick way to
draw shapes on the spreadsheet using the drawing space. The Drawing Tools menu contains several drawing-related
icons for setting the color, line thickness, location, scale, and orientation.

Select a block of cells and then select the Camera Shape icon to create a camera shape. The camera shape can include
other shapes. Use the Drawing Tools menu to customize the image. The BackColor and ForeColor options under
the DrawingTools menu do not apply to the camera shape. In general, properties that apply to the interior of the
shape, do not apply to the camera shape.

For more information on shapes in general and the drawing space, refer to Designing Shapes.

The following figure identifies the items in the Insert and Drawing Tools menus:
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Q 4 Picture gl Column - Bn Bar - v il IiII I@
@ Shapes - ¥ Line - @ Area -~ ) OtherCharts ~ o
1 A

Symbol  WordArt @ Annolation Mode @ Pie - L Scatter - Line Column  Win/Loss Sﬁhl’g;f:

Text lllustrations Chart = Delete Sparklines Camera shape

g oS H 'NET 2.0 Framework Edition) = e =)

Home Insert Page Layout Data View Settings Drawing Tools @
& BackColor -~ = Thickness ~ . Zh Rotate - = [ ‘G 2l

"4 Bring To Front - -
& ForeColor - == OutlineStyle ~ l_]ﬂ S”ng _DBank |= Flip ~ = e I
end To Bac
& OutlineColor - | Bk DropShadow - 4 f1 Scale - F'ic?ure 2 4 ™
Shape Style = Shape Arrange

The Shapes option in the Insert menu allows you to select one of the built-in shapes. The Shape Style section of the
Drawing Tools menu allows you to set colors, outlines, and shadows.

The Symbol option in the Insert menu allows you to put special characters in a cell (such as unicode characters).

The Drawing Tools and Insert menus provide additonal functions summarized in the table below.

Item Description

Shapes This allows you to select from a list of built-in (automatic) shapes. For a description of the
built-in shapes, refer to Designing Shapes.

Bring To Front or This allows you to customize the order of shapes which can be on top of each other. Move

Send To Back shapes to the front or back of other shapes.

Nudge The arrows to the right side of the Drawing Tools menu allow you to move the shape.

Rotate This allows you to select typical amounts of rotation for a shape.

Flip This allows you to flip a shape either horizontally or vertically.

Scale This allows you to resize a shape proportionally by selecting a scaling factor.
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Picture This allows you to select an image and the image properties.
Load, Save, or Delete  This allows you to load or save a shape to a file or delete a shape or shapes.

Word Art This allows you to create a text based shape.
You can right-click on a shape and select Properties from the menu to bring up the Shape Properties dialog.
Inserting Charts
The Insert menu is also used to create chart controls. Select a chart from the chart section of the Insert menu. This

brings up the Chart Tools toolbar. You can change the chart type, select data, switch rows and columns, move the
chart, or allow the user to move or resize the chart.

) ] I_j H GrapeCity Spread Dezigner [MET 3.5 Framework Edition] EI@
Home Insert Page Layout Data Wiew Settings Chart Tools @
N =3 N
i lﬂ, 4-? i _""'_ T} Bring to Front ] H} Allow Move : |Both - || & Move with Cells
Change Switch Select ﬂﬂ Send to Back Maove Allow Resize: | Both - || |#| Resize with Cells
ChartType Row/Column  Data Chart
Type Data Arrange Location Move & Size

The change chart type changes from the 2D to the 3D view.

The Move with Cells option will move the chart so that it stays with the original location (anchor) when you add or
insert columns or rows in front of the chart control. The Resize with Cells option will resize the chart control if you
resize columns or rows under the chart.

Inserting Sparklines
The Insert menu also has options for creating sparklines in cells.

Line
i Column E Camera Shape
= Win/Loss
Sparklines Camera shape

The Sparkline menu is displayed after you choose a sparkline type in the Insert menu. You can use the Sparkline
menu to set options such as marker colors and axis settings for the sparkline.

) [ ._j H GrapeCity Spread Deszigner [MET 3.5 Framework Edition) E@
Home Insert Page Layout Data Wiew Settings Sparklines @

~ - Line High Point First F'Ciirt & Sparkline Color ~ w’“’f

@ Column Low Point Last Point = Marker Color ~
Edit o . . B = .. HAocis -
Date = W Win/lLoss Megative Point Markers = \Weight - o Clear -
Sparkline Type Show Style Group
Inserting Tables

You can use the Insert menu to add tables. Select data in the data area and then select Table from the Tables section.
The TableTools menu is displayed and allows you to set options for the table such as name, size, and style.
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Q ) ] Lj H GrapeCity Spread Designer ((NET 2.0 Framework Edition) EI@
Home Inzert Page Layout Data View Settings TableTools @
Table Name: ¥| Header Row FirstColumn | FEEEE | === — -
oo ||| [EEEEE E===n f===== -
Table Total Row Last Column V| Filter Button || [—=———) Eo——of —————f |7
'il' Resize Table t,“'% Convert to Range ¥| Banded Rows Banded Columns L -
Properties Tools Table Style Options Table Styles

Page Layout Menu

The Page Layout menu can be used to set print options. You can specify margins, page
orientation, paper size, the print area, headers and footers (print title), and smart print options.
The Print Titles and Smart Print options bring up the Print Sheet Settings dialog.

e ) ™~ ] Lj H GrapeCity Spread Designer [MET. .. E=NEER "

Home Insert Page Layout Diata YView Settings @

E—"“. i [ 1 Tl === "I
e N e T
Margins Crientation Printhreea  Background PrinfTitles  SmartPrint

- - -

Fage Setup =

Data Menu

Starting with version 5, the Format menu of the designer has been replaced by the Data and
Settings menus. The Data menu appears as follows:

e ) o~ [ Lj H GrapeCity Spread Designer [.... E=NEol ="

Home Insert Fage Layout Diata WView Settings @

B m—
+ AlZ =]
Lg & 8| |zl =
Group . £l Sor Name
Manager
COutline Sort Defined Names

The Data menu allows you to create groups (outline grouping) or sort data.

Menu Description
Option
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Sort This allows you to sort rows or columns based on criteria you select. For more
information, refer to the Sort Dialog.

Group This allows you to create a range group.
Name This allows you to create, edit, or delete custom names.
Manager

View Menu

The View menu lets you determine whether headers, grid lines, or the formula bar is visible and the scaling
factor to zoom in to display the spreadsheet. You can also set frozen columns and rows. The toolbars are
described in more detail in Spread Designer Toolbars. The status bar is described in more detail in
Spread Designer Status Bar.

@ 7 o0 GrapeCity Spread Designer [NET 35 Framewark Edition) [(=E s

Home Insert Page Layout Data Wiew Settings 7]
Q 1 B =
7| Row Head 7| VerticalGridLi bR ZES
ow Header E-ICE ri -|ne. ' Eormuls Bar i mme -
¥ ColumnHeader | || HonzontalGridline Zoom  100% Zoomito Fresze
Selection Panes ~
ShowiHide Zoom Window

To freeze a row above the selected row, or to freeze a column to the left of the selected column, you can select
the Freeze Panes option. For more information, refer to setting up rows and columns in the Developer's
Guide (on-line documentation).

The Zoom options allows you to scale the display. This affects the size applied to the component or when
saved, on the display of the spreadsheet.

Settings Menu

Starting with version 5, the Format menu of the designer has been replaced by the Data and Settings menus.

The Settings menu gives you the ability to set properties of an entire spreadsheet, or rows or columns if either is
selected, or individual cells or a range of cells. From here you can launch the settings dialog boxes or change the height
of rows or width of columns. For information on the dialog boxes, refer to Spread Designer Dialogs.

Q g =12 H GrapeCity Spread Designer (NET 35 Framewark Edition] ESREORCx
Home Insert Page Layout Data View Settings (7]
2 General H SplitBox General £ Gridlines & SpreadSkin E Style " Grouplnfo
o Edit _\'\ View =25 Colors :'j Calculation % SheetSkin £=| TabStrip P Cells, Columns and Rows -
) a — i references
ScrollBars Titles T Headers ' Fonis & FocusIndicator AlternatingRow @ Input Map -
Spread Settings Sheet Settings Appearance Settings Other Settings Designer Settings

The Data menu allows you to create groups (outline grouping) or sort data.

The Settings menu options are grouped under Spread Settings, Sheet Settings, Appearance Settings, Other
Settings, and Designer Settings. The options are explained in the table below.
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Settings
Options

Spread Settings

Spread Settings

Sheet Settings

Sheet

Appearance Settings

TabStrip Editor

Focus Indicator
Editor

Style Editor
Spread Skin Editor
Sheet Skin Editor

Alternating Row
Editor

Other Settings

Cells

Columns

Rows

Grouplnfo
Input Map
Designer Settings

Save Split Bars on
Apply
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Description

When an entire Spread is selected, this allows you to customize properties of the FpSpread
component. For more information, refer to Getting Started Designing and Spread
Settings Dialog.

When a sheet is selected, this allows you to customize properties of the active sheet. For more
information, refer to Adding and Customizing Sheets and Sheet Settings Dialog.

This allows you to customize the tab strip. For more information, refer to the TabStrip
Editor

This allows you to customize the appearance of the focus indicator. For more information, refer
to the Focus Indicator Editor

This allows you to customize the style. For more information, refer to the Named Style
Editor

This allows you to create a skin for the Spread control. For more information, refer to the
SpreadSkin Editor

This allows you to create a skin for the sheet. For more information, refer to the SheetSkin
Editor

This allows you to set properties for alternating rows (such as backcolor). For more
information, refer to the Alternating Row Collection Editor

When a cell or range of cells is selected, this allows you to customize properties of the selected
cell or cells. For more information, refer to Setting Cell Properties in Spread Designer.

When a column or range of columns is selected, this allows you to customize properties of the
selected column or columns. For more information, refer to Setting Column Properties in

Spread Designer.

When a row or range of rows is selected, this allows you to customize properties of the selected
row or row. For more information, refer to Setting Row Properties in Spread Designer.

This allows you to create basic formatting for groups.

This allows you to create an input map for the keyboard keys.

With this preference checked, Spread Designer applies the split bars and viewports to the
spreadsheet; otherwise, the split bars would just be used while in the Spread Designer and lost

upon applying.
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Auto-Launch
Designer on New
Instance of Spread

Allow Designer
DragFill

Show Start-Up
Screen

Select Context Menu
Automatic

Show Property Grid

Show All
Conditional
Formatting Options

Help Menu

With this preference selected, the Spread Designer is automatically launched when a new
instance of the Spread component is placed on a Windows Form.

With this preference selected, drag fill works in the designer.

With this preference selected, the start-up screen in Spread Designer is displayed each time
Spread Designer is launched. With this option toggled, the Spread Designer does not display
that initial screen when launched.

With this preference selected, focus moves to the Drawing Tools or Chart Tools tab
automatically if you insert a shape or a chart.

If this preference is not selected, the property grid is not visible. Unchecking this option makes
the designer faster.

This option shows the conditional formatting with rules and the previous cell conditional
formatting options when a designer file that contains the previous cell conditional formatting
is loaded.

The Help menu icon located on the upper right side of the designer allows you to open the help
that is available for the Spread Designer.

E=E EEE 55

©

Sheet Context Menu

The sheet context menu allows you to cut, copy, delete, and paste sheets in the designer. Right-
click on a sheet icon at the bottom of the designer to bring up this menu and then select an

option.
11
H 4T w] Sheett == _
| Fready sheet{  °PY | 5e
Lut
Paste
Delete

Table Context Menu
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The table context menu allows you to add a totals row, convert the table to a data range, add
columns or rows, delete columns or rows, and select table items. Right click on a table in the
designer to display the table menu options.

coge

Cell Types »
Cut
Copy
Paste k
Clear
Select All b
Span
Lock
Borders...

I:E.:l Totals Row Table b

Convert to Range Insert .

Delete k
Select k
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3
- |Columua Colum®
5 Cell Types »
6 Cut
! Copy
g
Paste 3
9
10 Clear
11 Select All b
12
Span
13 P
14 Lock
15 Borders...
16 Table b
17
18 HT[HTEHECDMH'IHStDthELEﬂ Insert k
19 , Table Rows Abowve Delete 3
20 Select 3
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o

Cell Types *
Cut
Copy
Paste 3
Clear
Select All 3
Span
Lock
Borders...
Table 3
Insert 3
T
* Table Columns Delete b
=% Tahle Rows Select k
- |
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- I

Cell Types b

Cut

Copy

Faste 3

Clear

Select All k

Span

Lock

Borders...

Tahle b
Table Column Data Insert k
Entire Table Column Delete k

Table Row Select k

Spread Designer Toolbars

The toolbars provide easy access to some features of the Spread Designer. Several of the
toolbars are now part of the menu options (starting with version 5 of the control).

Click a button in the toolbar to perform the associated task.

For more information on drawing shapes, refer to the Insert Menu, and to Designing
Shapes. For more information on adding formulas to cells, refer to the Formula Bar, and to
the Formula Reference.

General Toolbar

The General toolbar has been replaced by the Home menu. The Home menu option contains
general file and editing operations, such as cut, paste, and print.

Cell Types Toolbar

The Cell Types toolbar has been replaced by the Home menu option. The Home menu
option lets you quickly set the cell type for a cell or range of cells.
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Formatting Toolbar

The Formatting toolbar has been replaced by the Home and Settings Menu options. These
options allow you to easily format text in a cell or range of cells. This includes spanning, locking,
and setting borders around cells.

Formula Bar

The formula bar of the Spread Designer provides a quick way to enter a formula for a cell or
group of cells.

The following figure identifies each item in the formula bar:

name box (with cell

coordinste) Cancel formula box
AT * (o o % = Sum[BZES]
| [
Apply Formula Choose
Formuls

The name box may contain the cell name or the cell reference of the active cell. If more than one
cell is selected, only the first or active cell name is shown. Click Equals or type equals to begin
the formula. This launches the Formula Editor. You may either use the Formula Editor or
type directly into the formula box.

The name box also displays custom names.

For more information on using the Formula Editor and entering a formula, refer to
Entering a Formula in Spread Designer. For more information on formulas and
functions, refer to the Formula Reference.

To display or hide the formula bar, from the View menu, select Formula Bar.
Drawing Toolbar
The Drawing Toolbar has been replaced by the Insert and Drawing Tools menus.

Spread Designer Data Area

When working in the data area of the Spread Designer, you can click on individual cells or a
selection of a row, column, or ranges of cells. Depending on what is selected, different options
are available for the cells in the selected item. For more information on selecting. refer to
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Selecting an Item in the Spread Designer.

Changes that you make in the data area, both content and formatted, can be saved or applied to
the Spread on the form.

All cell types (check box, button, etc.) do not react to the first click on cell selection. This allows
Spread Designer to set the selected cell(s) into the property window for property access. You
must double-click a cell for a change to occur; simply single clicking does not change the state of
the button.

Spread Designer Property Window

The property window provides a list of the properties for the currently selected object. The
following figure identifies the property window with its list of properties and associated item list
and description area:

= w
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MaleSiyle PopugMote
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Hacklolos
perE:.r‘t':.-r Gats o setz the background color for a cell
dezcription ——

Use the item list to select the object, or click on a sheet, column, row, or cell in the displayed
spreadsheet to select an object. Then set properties for that object using the property list.

To assist you with using Spread Designer, in design mode Spread Designer does not always
change settings for what is displayed on the screen. For example, if you set the sheet not to
display column headers, the column headers remain visible to help you with designing the
sheet. The following property settings are ignored at design time to assist you with your design:
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e ColumnHeaderVisible

o EditModePermanent

e HorizontalScrollBarPolicy
e RowHeaderVisible

e TabStripPolicy

e VerticalScrollBarPolicy

If you want to see the sheet with these settings applied, from the File menu icon choose
Preview. A preview of the run-time version of the FpSpread component is displayed.

If you set the tab strip ratio by dragging the tab strip bar, the new setting for the ratio is not
saved unless you make another change in Spread Designer or click the Properties list.

To set your preferences for the Spread Designer, from the Settings menu select Preferences,
and select the Save Split Bars on Apply if you want to save the split bar positions and
viewports you have created in Spread Designer when you apply your changes to the FpSpread
component.

You can also hide the Property window. Select Preferences under the Settings menu and
remove the check mark next to the Show Property Grid option.

Spread Designer Status Bar

The status bar of the Spread Designer provides information about the current component and the object
in the FpSpread component with which you are working.

In the following figure, the status bar shows that we are working with a Cells item and that a selection of
cells, from B3 (index 2,1) to D6 (index 5,3). The zoom factor is 100%.

L REEp Sheet(Sheet1] Selection [5.7)(5.7) 100 J

If you selected cell B4 in the top, right viewport for a sheet displaying four viewports, the selection would
read "Selection (3,1),(3,1)".

This table summarizes the possible selected items and their status notation:

Selected Selection Notation
Item

Cells The range of cells that are selected is indicated by the two sets of coordinates, the first
set of coordinates being the starting cell and the second set of coordinates being the
ending cell. If only one cell is selected, both beginning and ending cell coordinates are
the same. If you select all the cells in a sheet by selecting the sheet corner cell, the
coordinates (-1,-1)(-1,-1) indicate all the cells have been selected in all rows and all
columns.

Column The range of columns that are selected is indicated by the two sets of coordinates, the

first set of coordinates being the starting column and the second set of coordinates being
the ending column. The -1 indicates all the rows in that column. If only one column is
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selected, both beginning and ending column coordinates are the same.

Row The range of rows that are selected is indicated by the two sets of coordinates, the first
set of coordinates being the starting row and the second set of coordinates being the
ending row. The -1 indicates all the columns in that row. If only one row is selected, both
beginning and ending row coordinates are the same.

Sheet The name of the sheet indicates which sheet is selected. (You cannot select more than
one sheet in the Spread Designer.)

If you select all the cells in a sheet by selecting the sheet corner cell, the coordinates (-1,-
1)(-1,-1) indicate all the cells have been selected in all rows and all columns.

Spread Simply the word "Spread" indicating the entire Spread component.

For more information about selecting items, refer to Selecting an Item in the Spread Designer
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Spread Designer Dialogs

The dialog boxes of the Spread Designer provide a quick way of setting properties and
customizing your Spread component. There are settings dialogs that are available from the
menus and design properties.

For more information on the individual dialog boxes, refer to the detailed description of each.

¢ Cell Type Dialog

¢ Conditional Formatting Dialog

¢ Custom File Options Dialog

e Go To Cell Dialog

¢ Name Manager Dialog

¢ Row Height or Column Width Dialog

¢ Row or Column Insert or Delete Dialogs
¢ Shape Properties Dialog

¢ Shape Shadow Properties Dialog

¢ Sheet Settings Dialog

¢ Sheet Print Settings Dialog

e Sort Dialog

¢ Spread Settings Dialog

¢ Unhide Specific Row or Column Dialogs
e Zoom Dialog

For a list of editor dialogs, see the Spread Designer Editors.

Cell Type Dialog

You can customize the settings of the cell type using the Cell Type dialog of the Spread Designer. Each
cell type has a separate tab in this dialog with its own group of settings particular to that cell type. To
change the settings, simply click in the edit fields or select the choices. To select another cell type, simply
select that cell type from the drop-down list at the top of the dialog.

If you have more than one cell selected, the dialog box shows only settings that are common to all the cells
selected. So if you have one parameter set for one cell but another setting for other cells, then the setting
does not appear in the dialog.

To open this dialog in the Spread Designer, click on a particular cell type icon in the Cell Types option in
the Home menu, or select cells in the data area of the spreadsheet, right click, and select Cell Type from
the context menu.

This image displays the Cell Type dialog from the Home menu.
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This image displays the Cell Type dialog from the context menu.
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ShadowSize:
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Apply

Help

For more information on the individual settings, refer to Customizing Interaction with Cell Types

(on-line documentation). For more information on how to set properties of cell types in code, refer to

the FarPoint.Win.Spread.CellType ('FarPoint.Win.Spread.CellType Namespace' in the on-

line documentation) namespace.

If you have a question about a particular cell type, refer to the topic about that tab. This dialog has the

following tabs corresponding to the available cell types:

BarCode Tab
Button Tab

Check Box Tab

Color Picker Tab
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Combo Box Tab
Currency Tab
Date-Time Tab
General Tab
Background Tab
GcDateTime Tab
GcTextBox Tab
Hyperlink Tab
Image Tab

Label Tab
ListBox Tab
Mask Tab
MultiColumnComboBox Tab
MultiOption Tab
Number Tab
Percent Tab
Progress Tab
Regular Expression Tab
Rich Text Tab
Slider Tab

Text Tab

BarCode Tab
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The Barcode tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the

bar code cell type that can be applied to cells. These are organized on the General and Appearance

sub-tabs.
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L] Cell Type

LelType: BarCode W

BarCode
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Fix Length: -1 =
Check Digit i
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() Code3d () Codedd () Coded3 () Codel28
() EAN12S ) ITF () JaNg () JEN13
() JP Paostal ) MW7 (") PDFAT () Posthet
() QRCode @ UFC
Details
Ok Cancel Apply Help

For information on the individual properties, refer to the BarCodeCellType ('BarCodeCellType
Class' in the on-line documentation) class in the Assembly Reference.

For more information on the button cell type, refer to Setting a Barcode Cell (on-line
documentation) in the Developer’s Guide.

Button Tab

The Button tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
button cell type that can be applied to cells. These are organized onto the General, Color, and Picture
sub-tabs of the Button tab.
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Cancel
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For information on the individual properties, refer to the ButtonCellType ('ButtonCellType Class' in
the on-line documentation) class in the Assembly Reference.

For more information on the button cell type, refer to Setting a Button Cell (on-line

documentation) in the Developer’s Guide.

Check Box Tab

The Check Box tab of the Cell Type dialog in the Spread Designer contains the settings for customizing

the check box cell type that can be applied to cells.
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L] Cell Type

CellType: CheckBox v
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For information on the individual properties, refer to the CheckBoxCellType ('CheckBoxCellType
Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the check box cell type, refer to Setting a Check Box Cell (on-line
documentation) in the Developer’s Guide.

Color Picker Tab

The Color Picker tab of the Cell Type dialog in the Spread Designer contains the settings for
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customizing the color picker cell type that can be applied to cells.

< Cell Type

Celllppe: CalarPicker v
ColarPicker
Captiot;
AllowFull0pen [ ] AwwColar
[ ] SolidColarOnly [ ] DropDown [ ] FullDpen
Fill
) Fill () Fillafith T et () Boxed (@ BoxedwithText
Uk riownT et

UnknownT extStyle

(@) Blank () Mame () CustomMame

B oxhwfidth -1 -

Q. Cancel Apply Help

For information on the individual properties, refer to the ColorPickerCellType
('ColorPickerCellType Class' in the on-line documentation) class in the Assembly Reference.

For more information on the check box cell type, refer to Setting a Color Picker Cell (on-line
documentation) in the Developer’s Guide.

Combo Box Tab

The Combo Box tab of the Cell Type dialog in the Spread Designer contains the settings for customizing
the button cell type that can be applied to cells.
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L] Cell Type
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ak. Cancel Apply Help

For information on the individual properties, refer to the ComboBoxCellType ('ComboBoxCellType
Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the combo cell type, refer to Setting a Combo Box Cell (on-line
documentation) in the Developer’s Guide.

Currency Tab

The Currency tab of the Cell Type dialog in the Spread Designer contains the settings for customizing
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the currency cell type that can be applied to cells.
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@

CellType:

Currency | Background

b aximunmty alue:;

MinirnLm® alue;

DecimalPlaces::

FiedPaint

TextOnentation;

[ ] wiordwrap

Buttandlign

StringT rinn;

[ ] ReadOrly

General | Format | Spin

Aoceptzdrrowlens:

Cell Type

Currency

555335599
-33333349.99
R =
[] Shrink ta fit display
TextHorizantal
[] DropDownButton
Right

Alldrrans

Maone

[ ] Static

Ok Cancel

1 F

Apply

Help

For information on the individual properties, refer to the CurrencyCellType ('CurrencyCellType

Class' in the on-line documentation) class in the Assembly Reference.

For more information on the currency cell type, refer to Setting a Currency Cell (on-line

documentation) in the Developer’s Guide.

Date-Time Tab

The DateTime tab of the Cell Type dialog in the Spread Designer contains the settings for customizing
the date-time cell type that can be applied to cells.
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LelType: DateTime

DateTime | Background

General | Symbols | Format | Day

L] Cell Type

taonth | ShortDay | Shortbonth | Calendar

I~

M axirnumnD ate: |1 £431/9999
MinimumD ate: {1/1/000

M i Tirne: 2x5%:59
Minirnurn T ime: 00:00:00

TextOrnentation: TextHonzontal

[ ] wiordwrap [] SpinButton
Acceptsdmowkeys: All&rrows
String T rirn: Mane

[_| DropDowrButton [] Shrink ta fit display

Buttorndlign Right

[ ] ReadOrly [ ] Static

Ok

[ SimpleE dit

Cancel

Text

4k

Apply

I~

1k

4k

Help
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For information on the individual properties, refer to the DateTimeCellType ('DateTimeCellType

Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to

Background Tab.

For more information on the date-time cell type, refer to Setting a Date-Time Cell (on-line

documentation) in the Developer’s Guide.

General Tab

The General tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
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general (or generic) cell type that can be applied to cells.

o Cell Type
CellType: General N
General | Background
General | DateTime | Mumber
FormatString:;
T extOrientation: TextHarizontal W
[ wordwrap [ Shrink ta fit display
* -
Acceptsdrrowkeys: Alldrrows v ~
String T rirn: Mone W Tewt— +
[ | DropDownButton . ’
*
Buttondlign Right W
0z
[ | ReadOnly [ ] Static
HullDizplay:
Q. Cancel Apply Help

'

For information on the individual properties, refer to the GeneralCellType ('GeneralCellType Class
in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the general cell type, refer to Setting a General Cell (on-line
documentation) in the Developer’s Guide.

Background Tab
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The Background tab of the Cell Type dialog in the Spread Designer contains the settings for

customizing the background that can be applied to cells.
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< Cell Type
CellT ype: Test W
Text | Background
Image: TransparencyColar:
Mat Set
TranzparencyT olerance: 0
AlignHaorz: Left W
Aligriert: Top W
Syl Marmal v
Q. Cancel Apply Help

GcDateTime Tab

The GeDateTime tab of the Cell Type dialog in the Spread Designer contains the settings for
customizing the GeDateTime cell type that can be applied to cells.
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o Cell Type
CellType: GeDateTime

GeDateTime | Background
General | Fields | DisplayFields | DropDown | SideButton | DropDownCalendar

Walue

Appearance
Recommended alue [] Show Recom. Value PramptChar
A
kM axDrate MinD ate -
993912/ 238953 W | (00070707 Q00000 w ] ReadOnly
b axbdinB ehavior :
Action
B R - FocusPosgition:
Edit [nherit
ClipContent Edittdode Acceptsdrowkeys:
Includeliterals W Inzert e
All&rrows
AoceptzCrLE .
NaControl v [ ] ExitOnLastChar
ValidateMode FieldsE ditdode Defaulthctiverieid
YalidateE = W LeftSide W [hange]

ak. Cancel Apply

Help

For information on the individual properties, refer to the GeDateTimeCellType

('GeDateTimeCellType Class' in the on-line documentation) class in the Assembly Reference.

For more information on the GeDateTime cell type, refer to Setting a GeDateTime Cell (on-line

documentation) in the Developer’s Guide.

GcTextBox Tab

The GeTextBox tab of the Cell Type dialog in the Spread Designer contains the settings for customizing

the GcTextBox cell type that can be applied to cells.
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< Cell Type

CellType: GeTextBox i

GeTextBox | Background

General | pultline | Format | DropDown | DropDownEditor | SideButton | AutaComplete

Text Appearance

Recammendedy alue PazswardChar
[ ] Show Recom, Yalue

[ ] UseSystemPazzwordChar

E dit
E dithd ode [ Readdniy
Inzert W Achion
AcceptsCrLf FocuzPogition:
MaControl L Inherit L
MasLength Acceptetromkens:
03 Al o W
MaxLengthlUnit [ ] ExitOnLastChar
Char W

AutaCornert

ak. Cancel Apply Help

For information on the individual properties, refer to the GeTextBoxCellType ('GcTextBoxCellType
Class' in the on-line documentation) class in the Assembly Reference.

For more information on the GeTextBox cell type, refer to Setting a GeTextBox Cell (on-line
documentation) in the Developer’s Guide.

Hyperlink Tab

The Hyperlink tab of the Cell Type dialog in the Spread Designer contains the settings for customizing
the hyperlink cell type that can be applied to cells.
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L] Cell Type

CelType: HyperLink W
Hyperlink | Background

Teut:

Enter the hyperlink data in the link editor below:

4 HyperLinks
= Links HyperLink[] Armray

LinkColar:

WisitedLink Calar: -

Strirg T rirm; Mot "

ak. Cancel Apply Help

For information on the individual properties, refer to the HyperLinkCellType ('HyperLinkCellType
Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the hyperlink cell type, refer to Setting a Hyperlink Cell (on-line
documentation) in the Developer’s Guide.

Image Tab

The Image tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
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image cell type that can be applied to cells

< Cell Type

CellType: Image W
[mage

Image: TransparencyColar:

Mat Set
Transparency Tolerance: 0
Style: Marmal v
Q. Cancel Apply Help

For information on the individual properties, refer to the ImageCellType ('ImageCellType Class' in
the on-line documentation) class in the Assembly Reference.

For more information on the image cell type, refer to Setting an Image Cell (on-line
documentation) in the Developer’s Guide.

Label Tab

The Label tab of the Cell Type dialog in the Spread Designer contains the settings for customizing an
un-editable label cell type that can be applied to cells.
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L] Cell Type

CellT ype: L ahel W

Label | Background

Caption:

[] MultiLine

[ ] Wordwrap
TextOrientation: TextHarizantal ~

TertRatationdngle:; 1

1k

Strirg T rirm; Mare "

MullDizplay:

ak. Cancel Apply Help

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

ListBox Tab

The ListBox tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
list box cell type that can be applied to cells.
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@

CellT ype:

LiztBox
General | |kems
E ditar alue:

() Shing

[temHeight:

Selectiontdode:

LiztBox

® Index

One

Cell Type

(1 ItemData

Ok

Cancel

Apply Help

For information on the individual properties, refer to the ListBoxCellType Class (on-line
documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to

Background Tab.

For more information on the list box cell type, refer to Setting a List Box Cell (on-line

documentation) in the Developer’s Guide.

Mask Tab

The Mask tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide

mask cell type that can be applied to cells.
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@

Mazk | Background

M azkCharacter;

TextOrientation:

MHullDizplay:

CellType: Mask

General | Mazk | Custom Mask Characters

[ | whordw/rap

Acceptsfnowteys: Al o
String T rir; Maone

[ ] DropDownButtan

Buttondlign Right

[ ] ReadOrly [] Static

TextHaorizontal

Cell Type

[] Shirink to fit display

OF.

Cancel

+*

Text
L
Apply

+*

Help

For information on the individual properties, refer to the MaskCellType ('MaskCellType Class' in
the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to

Background Tab.

For more information on the mask cell type, refer to Setting a Mask Cell (on-line documentation) in

the Developer’s Guide.

MultiColumnComboBox Tab
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The MultiColumnComboBox tab of the Cell Type dialog in the Spread Designer contains the settings
for customizing the multiple-column combo box cell type that can be applied to cells.

o Cell Type
CellType: tulbiCalurmnComboB ox A
MulbCalurmnComboBox | Background

General | [tems | List
Acceptztorowk ey Arows W
AutoSearch: SingleCharacter v
String T rirn: MHione W
ColurnnE dit; 1] =
[] Editable
Q. Cancel Apply Help

For information on the individual properties, refer to the MultiColumnComboBoxCellType
('MultiColumnComboBoxCellType Class' in the on-line documentation) class in the Assembly
Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the multi-column combo cell type, refer to Setting a Multiple-Column
Combo Box Cell (on-line documentation) in the Developer’s Guide.

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide 55

MultiOption Tab

The MultiOption tab of the Cell Type dialog in the Spread Designer contains the settings for
customizing the multiple option cell type that can be applied to cells.

L5 Cell Type

CellType: b Lt ptiom v

Multiption | B ackground

General | [tems | Pictures

E ditory alue:
) Sting @ Index () ItemData
Origntation;
(®) Vertical () Horizantal
Textalign: Text right of Picture v

[ ] UserMnemonic

k. Cancel Apply Help

For information on the individual properties, refer to the MultiOptionCellType
('MultiOptionCellType Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the multiple option cell type, refer to Setting a Multiple Option Cell (on-
line dociimentation) in the Develoner’s Guide.
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Number Tab

The Number tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
number cell type that can be applied to cells.

L5 Cell Type
CellType: Murmber W
Mumber | Background
Gereral | Format | Spin | Symbols | Fraction
b arirumt alue; 3399393.99 =
Minirmury alue: 29999999 99 =
DecimalPlaces: R =
FixedPoint [] Shrink ta fit dizplay
- *
TextOrientation: TextHorizontal v ~
[ ] wiordwrap [ ] DropDownButton .
Text *
Buttondlign Right W :
*
Acceptsdmowkeys: All&rrows W .
String T rir: Muone W o=
[ ] BeadOnly [ ] Static
k. Cancel Apply Help

For information on the individual properties, refer to the NumberCellType ('NumberCellType Class'
in the on-line documentation) class in the Assembly Reference.

For more information on the number cell type, refer to Setting a Number Cell (on-line
documentation) in the Developer’s Guide.
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Percent Tab

The Percent tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
percent cell type that can be applied to cells.

L5 Cell Type

CelType: Percent W

Percent | Background

Leneral | Format | Spin | Symbols

b gL’y alue: 9339333.593 =
M irirnointy alue: -9999999.99 -
DecimalPlaces: R =
[ ] FixedPaint

*
TestOnentation: T estHarizontal v - .
[ ] wiordwrap [] Shrink ta fit dizplay ’

Text *
[ ] DropDownButton . ]

*
Buttondlign Right v e
doceptsdmowk ays: Al rows » o =
String T rirn: Mone "
[] ReadOnly [ Static
k. Cancel Apply Help

'

For information on the individual properties, refer to the PercentCellType ('PercentCellType Class
in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the percent cell type, refer to Setting a Percent Cell (on-line
docnnmentation) in the Develoner’s Gnide.
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Progress Tab
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The Progress tab of the Cell Type dialog in the Spread Designer contains the settings for customizing
the progress indicator cell type that can be applied to cells.

o Cell Type
CellType: Frogress
Frogress | Background
General | Appearance | Fill Dptions

b xirniuart alue: 100

Minirnumty alue: 1]

Walue: 0

Text:

)4

Cancel

Apply

Help

For information on the individual properties, refer to the ProgressCellType ('ProgressCellType
Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to

Background Tab.

For more information on the progress cell type, refer to Setting a Progress Indicator Cell (on-line

documentation) in the Develoner’s Guide.
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Regular Expression Tab
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The RegularExpression tab of the Cell Type dialog in the Spread Designer contains the settings for
customizing the regular expression cell type that can be applied to cells.

@

CellType:
RegularE xpression | Background
Requlark =pression:

Testdrientation;

[] Wordwirap
Acceptzdromwkeys:

StringT rirn;

[ ] DropDownButton

Buttanalign

[ ] ReadOnly

MullDizplay:

Cell Type

Requlark <pression W

“d§

TextHorizontal v

[ ] Shrink to fit dizplay

ALy *
Mows W .
Maone W )
Text *
*
*
Right W —
[ ] Static
k. Cancel Apply

Help

For information on the individual properties, refer to the RegularExpressionCellType
('RegularExpressionCellType Class' in the on-line documentation) class in the Assembly

Reference.

For information on the Background tab for customizing the background of this cell type, refer to

Background Tab.

For mare information on the resular exnression cell tvne. refer to Settine a Resnlar Fxnression Cell
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(on-line documentation) in the Developer’s Guide.

Rich Text Tab

60

The Rich Text tab of the Cell Type dialog in the Spread Designer contains the settings for customizing
the rich text cell type that can be applied to cells.

@

RichText | Backaoround

b axlength:

[ ] MultiLine

ScrollB ars:

[ ] wordwrap

[ ] ReadOnly

CelType: RichT ext

255

Mane

[ ] Static

Cell Type

Ok

Cancel

Apply

Help

For information on the individual properties, refer to the RichTextCellType ('RichTextCellType
Class' in the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to

Background Tab.
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For more information on the rich text cell type, refer to Setting a Rich Text Cell (on-line
documentation) in the Developer’s Guide.

Slider Tab

The Slider tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the
slider cell type that can be applied to cells.

L5 Cell Type

CellTppe:; Slider W

Shder | Background

General | Knob | Track

M aRirnur alue; 10 -
Minirnrnt alue:; 0 =
W alue: 0 =
Origntation;
() Wertical (@ Horizontal
() VerticalBattarnTaT op () HorizontalRightToLeft

[ ] ChangelnFocus

TickSpacing: 1 =
TickLength: p] =
k. Cancel Apply Help

For information on the individual properties, refer to the SliderCellType ('SliderCellType Class' in
the on-line documentation) class in the Assembly Reference.

For information on the Background tab for customizing the background of this cell type, refer to
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Background Tab.

For more information on the slider cell type, refer to Setting a Slider Cell (on-line documentation)
in the Developer’s Guide.

Text Tab

The Text tab of the Cell Type dialog in the Spread Designer contains the settings for customizing the text
cell type that can be applied to cells.

o Cell Type
CelT ype: T et v
Test | Backaground
Gerneral | Farmat
ScrollB ars: Maone W
T extOrientatior; TextHonzontal hd
[ | whordwrap [ Shrirk ta fit display
. .
Acceptsfrowk ens Alltrrows W . *
Strirng T rirn: MNare v Text f
[] ReadOnly [] Static .
. .
[ ] DropDownButtan oz
Buttordlign Riight W
QK Cancel Apply Help

For information on the individual properties, refer to the TextCellType ('TextCellType Class' in the
on-line documentation) class in the Assembly Reference.
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For information on the Background tab for customizing the background of this cell type, refer to
Background Tab.

For more information on the text cell type, refer to Setting a Text Cell (on-line documentation) in
the Developer’s Guide.

Conditional Formatting Dialog

You can create conditional formatting with the Conditional Formatting dialog. This dialog is
located under the Home menu and appears as follows:

= 4] Lock
3 % Clear Al
Conditional , .
Formatting 'h i SelectAll -

114

Lag
_| _gl}l HighLight Cells Rules

| ﬂ“il Top/Bottom Rules b

| | | | Color Scales b
W=
| e |1mn Gets b

| Mew Rules,..
5 Clear Rules b

] Manage Rules...

This dialog has the following items:

Item Description

Highlight Cells Rules (on-line Rules used to apply formatting options to values that
documentation) meet specific conditions

Top Bottom Rules (on-line Rules used to apply formatting options to top or
documentation) bottom values

Data Bars (on-line Rules used to apply color bars to values
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documentation)

Color Scales (on-line
documentation)

Icon Sets (on-line Rules used to apply icons to values

documentation)

New Rules (on-line Additional rule options

documentation)

Clear Rules Clear all rules or rules for selected cells

Manage Rules (on-line
documentation)

64

Rules used to apply color or color gradients to values

Rules manager used to create, edit, or delete rules

For more information about conditional formatting, refer to Using Conditional Formatting

of Cells (on-line documentation).

Custom File Options Dialog

You can specify the various delimiters for opening the text file by setting the options in the
Custom File Options dialog of the Spread Designer. This dialog appears in Spread Designer

when you open a text file (File Menu icon > Open).

Lo Custom File Options

Special Delimiters

Calurnn Delimiter

Default
Tab «<tab:
Raw Delimiter cor<fs EIEHIEIQE-' return < cr
Line feed <IF:
amans rehiradl ine Fead ool b
Cell Drefimiter i < ?
Include Headers
[ ] Data contains farmatting
[ ] Coalurn
[ ] Fiow
If you clear the delimiter edit fields, default delimiters will be uzed.
]
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The Custom File Options dialog provides the following items:

Item Description

Column Set the character or characters that serve as the column delimiter (often a
Delimiter tab, such as in tab-delimited files)

Row Delimiter Set the character or characters that serve as the row delimiter (often a

carriage return or line-feed)

Cell Delimiter Set the character or characters that serve as the cell delimiter (often double
quotes)

Include Headers Set whether to treat the first column and row of data as headers

Special Insert special characters in the delimiters boxes using the controls in this
Delimiters area

Data contains Set whether the data includes formatting

formatting

For more information on the options for opening a custom text file, refer to Opening a Custom
Text File (on-line documentation) in the Developer’s Guide. For more information on how to
do this in code, refer to the LoadTextFile ('LoadTextFile Method' in the on-line
documentation) methods.

Go To Cell Dialog

You can move the view to include any cell in the sheet and make that cell the active cell, by
using the Go To Cell dialog of the Spread Designer. This dialog appears in Spread Designer
when you use the Home > Find icon (Editing section) > Go To option.

@ Go To Cell

Enter a cell reference, in A1 notation, to go to: [e.g. C3)

OE. Cancel

Name Manager Dialog
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You can create, edit, or delete custom names in the Spread Designer. You can also filter the list of

custom names by scope or error status. The Name Manager dialog is located under the Data
menu in the Spread Designer.

Mame Manager

MHew. .. Edit... Delete Filker -
M ame W alue Refers ta Scope Commetnt
=) M arne] 3 =Sheet1 15451 First custam name
=l Mamed 4 =Sheet113$B$1 Sheetl Second custom ...
=l Mame3 =Sheet11$CE2 "Workbook Test comment
Refers ho:
X =Sheetll$ag
Close
The following buttons allow you to work with custom names.
Button Description
New ('New Click the New button to display the New Name dialog box. This allows you
Button' in the to enter a range name and cell location. You can also click the Collapse
on-line button which allows you to use the mouse to select the desired cell(s). Press
documentation) Enter or click Expand to return to the New Name dialog box.
Edit ('Edit Click an existing range name and then click the Edit button (or double-click
Button' in the the name), to display the Edit Name dialog box. Use this dialog box to
on-line change the range name or the cell range location reference.
documentation)
Delete Click an existing range name and then click the Delete button. A

confirmation message appears to confirm that you wish to delete the range

name.
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Filter ('Filter Click the Filter drop-down to create a subset of the custom names based on
Button' in the scope or error status.

on-line

documentation)

Close Click the Close button to return to the Spread Designer.

The Name Manager dialog has the following columns for the custom names.

Column Description

Name The first character of a custom name must be a letter, an underscore character (_), or
a backslash (\). Remaining characters in the name can be letters, numbers, periods,
and underscore characters. The uppercase and lowercase characters "C", "c¢", "R", or
"r'" cannot be used as a defined name, because they are used as shorthand for

selecting a row or column for the currently selected cell in a Name or Go To text box.

Names cannot be the same as a cell reference. Spaces are not allowed as part of a

name. A name can contain up to 255 characters. Spread does not distinguish

between uppercase and lowercase characters in names.

Value The current value of the name, such as the result of a formula, a string constant, a cell
range, an error, an array of values, or a placeholder if the formula cannot be
evaluated. If the name refers to a cell range, all the values in the range are displayed

by row, from top to bottom, and are separated by a ";" character. All values are
wrapped with " ". For example, {"a","b";"c","d"}.

Refersto  The current reference for the name. For example, Sheet1!$C$2.

Scope The scope of a name is the location within which the name is recognized without
qualification. The scope can be a sheet (local Sheetview level) or a workbook (global
Spread level). For example, Name1 is only recognized in Sheet1 since the scope is
Sheet1. In order to use Name1 in Sheet2, qualify it by preceding it with the sheetview
name such as Sheet2!Name1. A name must be unique within its scope; however, you
can use the same name in different scopes. The local sheetview level takes precedence
over the global spreadview level if there is a name conflict.

Comment Additional information about the name and can be up to 255 characters.

You can sort the list of names in ascending or descending order by clicking the column
header. Double-click the right side of the column header to automatically size the column to fit the
largest value in that column.

Row Height or Column Width Dialog

You can set the dimensions of a row or column, or a set of rows or columns in the Row Height
or the Column Width dialog of the Spread Designer. To open the dialog, right-click on the
selected row or column and choose the Row Height or Column Width menu item. The Row
Height dialog or Column Width dialog appears, as shown in the figure. To change the
setting, simply type a number and click OK.
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@ Row Height @  ColumnWidth

Row Height: 20| Calumn width:

(np]

Qk. Cancel aFk. Cancel

For more information on the options for row or column size, refer to Setting the Row Height
or Column Width (on-line documentation) in the Developer’s Guide. For more details on
how to do this in code, refer to the Height ('"Height Property' in the on-line
documentation) property in the Row ('"Row Class' in the on-line documentation) class
or the Width ("Width Property' in the on-line documentation) property in the Column
('Column Class' in the on-line documentation) class.

Row or Column Insert or Delete Dialogs

You can add or remove rows and columns from the sheet using the Spread Designer. Select a
row or column on the spreadsheet to indicate where to insert the rows or columns, or select the
rows and columns to remove. To open this dialog, right-click on the row or column, and select
Insert to add rows or columns or Delete to remove rows or columns. The figure below shows
each of the the dialogs that can be brought up. Type in the number to insert and click OK.
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50 ] Insert Rows
Pleaze enter the nurnber of rows to ingert
o Delete Rows
Fleaze enter the nurber of rows to delete

Q Insert Columns

Fleaze enter the number of columnz ta ingert

@ Delete Columns

Fleaze enter the number of columnz o delete

Ok Cancel

For more information on the addition or removal of rows or columns, refer to Adding a Row
or Column (on-line documentation) and Removing a Row or Column (on-line
documentation) in the Developer’s Guide. For more details on how to do this in code, refer to
the various methods in the SheetView ('SheetView Class' in the on-line
documentation) class or the DefaultSheetDataModel ('DefaultSheetDataModel
Class' in the on-line documentation) class.

Shape Properties Dialog

You can change the properties of a shape using the Spread Designer. You can use the Insert
and Drawing Tools menu options or you can use the Shape Properties dialog. To open this
dialog, select a shape and then right-click and select Properties from the context menu. The
Shape Properties dialog appears, an example of which is shown here. In the example shown,
an ellipse is drawn and the background color is changed to orange.
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Shape Properties n
Preview = ﬁl |
=2 E
4 Appearance s

AlphaBlendB act 255
AlphaBlendShar 128

CEEEEERSN I DarkCyan v

Backgroundima [ ] [hone]

Font [hione]
ForeColar Bl ControlText
Foregroundimac[ | [none]
Picture [ ] [hone]

PictureTranzpar [
PictureTranzpar 0
Rotationdngle | 0 n
- 1 P [ o I
BackColor
Getz or gets the backcolor for the element.

Preview Area Background Color k. Cancel

This list of properties is different from the list of properties for the cell that appears in Spread
Designer. When you have a shape selected, do not use the list of properties in the main Spread
Designer window. Make sure that you select Properties from the context menu with a shape
selected.

The Shape Properties dialog allows you to further customize the shape once it is inserted in
the drawing space. By displaying a preview of the shape and showing the list of properties, the
Shape Properties dialog adjusts the preview as you change the properties in the list.

For more information on the menu that allows you to access this dialog, refer to the Insert
Menu.

For more information on the properties for the TextShape object, refer to Customizing Text
as a Shape.

Shape Shadow Properties Dialog

You can add a drop shadow to a shape using the Spread Designer. Most of the time, you may
simply add a standard shadow using the choices from the Drop Shadow option in the
Drawing Tools menu. To create a custom shadow, you need to change any of the shape
properties. To do this, use the Shadow Properties dialog. To open the Shadow Properties
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dialog, from the Drawing Tools menu, click the Drop Shadow option and select Custom.
The Shadow Properties dialog appears, an example of which is shown here. The table below
explains the properties related to drop shadows.

Shadow Properties
Shadow Direchion Right W
Shadow Color DarkGray
Shadow AlphaBlend 12815
Horizontal Offset als
Wertical Offset als
OE. Cancel

This dialog has the following items:

Item Description

Shadow Direction of the shadow relative to the selected shape

Direction

Shadow Color of the shadow; three numbers are the RGB values

Color

Shadow Amount of alpha-blending, from o0 to 256, where 0 is no blending and

AlphaBlend completely opaque, and 256 is completely transparent

Horizontal  Size of the shadow, the amount of horizontal width of the shadow in pixels
Offset

Vertical Size of the shadow, the amount of vertical width of the shadow in pixels
Offset

For more information on adding a shadow to a shape, refer to Adding a Drop Shadow.
Sheet Settings Dialog

You can set the sheet (SheetView object) properties using the Sheet Settings dialog of the
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Spread Designer. To open this dialog, from the Settings menu, select an option from the Sheet

Settings area. Each of the tabs in the dialog has a group of settings. To change the setting,

simply click in the edit field or select the choice. For more information on the individual
settings, refer to the properties of the SheetView ('SheetView Class' in the on-line

documentation) class. When finished making changes on all tabs, click OK. If you wish to
apply the changes from the active tab, click Apply and then click on the next tab of settings to

review or change.

@ Sheet Settings

General | Colors | Headers | Grid Lines

Column Count: RO

Row Count:; R00

[ ] Restrict Calumnsz
[ ] Restrict Rows

Frozen Column Count;
Frozen Row Count;
Trailing Frozen Column Count:

Trailing Frozen Row Count:

Protect

This dialog has the following tabs:
Tab

General Tab (on-line
documentation)

Colors Tab (on-line
documentation)
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() Single Select

4
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] Cancel

Description
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Headers Tab (on-line Properties related to the row headers and column
documentation) headers of the sheet

Grid Lines Tab (on-line Properties related to the grid lines on the sheet
documentation)

Calculations Tab (on-line Properties related to the calculation of formulas in the
documentation) cells on the sheet

Font Tab (on-line Fonts for null values or locked or selected cells
documentation)

For more information on changing properties in code to change the sheet appearance, refer to
Customizing the Individual Sheet Appearance (on-line documentation) in the
Developer’s Guide.

For more information on changing properties in code to change the user interaction with a
sheet, refer to Customizing Interaction with a Sheet (on-line documentation) in the
Developer’s Guide.

Sheet Print Settings Dialog

You can set the sheet print settings using the Sheet Print Settings dialog of the Spread Designer.
To open the dialog, from the Page Layout menu, select Print Titles or Smart Print. In the
dialog, various settings are organized on individual tabs. For more information on these settings,
refer to the members of the PrintInfo ('PrintInfo Class' in the on-line documentation)
class. When finished making changes, click OK.
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50} Sheet Print Settings

General | SmartPrint | Output | Header/Footer | Pagination | Margins

[] Preview Only Frinter M arme:
Frint Jaob M ame:

Abort Message:

[ ] Best Fit Columns
Print Only Fows with D ata

74

[ ] Best Fit Fows
Zoan; 0 % [0 uzes the sheet ZoomF actor]
Ok Cahcel
This dialog has the following tabs:
Tab Description
General Tab (on-line documentation) General settings for the print job
SmartPrint Tab (on-line Settings for letting Spread optimize the printing
documentation)
Output Tab (on-line documentation) Output layout settings
Header/Footer Tab (on-line Customization of the headers and footers of the
documentation) printed pages
Pagination Tab (on-line Settings relating to the pages of the printed job
documentation)
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Margins Tab (on-line Settings relating to the margins of the printed pages
documentation)

For more information on printing sheets, refer to Managing Printing (on-line
documentation) in the Developer’s Guide.

Sort Dialog

You can sort rows or columns using the Sort dialog of the Spread Designer. To open this dialog,
from the Data menu, select the Sort icon. In the Sort dialog, as shown in the figure, select what
to sort and the order of sorting. When done, click OK.

@ Sort

Sort by:

® Rows ) Columns

Tst Ky

(@ Azcending

Calumn & -
() Descending

2nd Kew:

(nione]

Ird ey

[hione]

[ ] Move Entire Fiow

] Cancel

This dialog has the following items:
Item  Description
Sort by Set whether to sort by content in rows or columns (Sorting by rows moves rows
based on columns as keys; sorting by columns moves columns based on rows as

keys)
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1st Key Set the first sort key (column or row on which to sort first)
2nd Key  Set the second sort key (column or row on which to sort second)
3rd Key Set the third sort key (column or row on which to sort third)

Move Select to move entire rows or columns when sorting instead of moving just the
Entire data in the selected rows or columns
Rows

Move
Entire
Columns

For more information on the sort settings, refer to Managing Data on a Sheet (on-line
documentation) in the Developer’s Guide.

For more information on how to do this in code, refer to the SortInfo ('SortInfo Class' in
the on-line documentation) class.

Spread Settings Dialog

You can set several properties of the entire spreadsheet component using the Spread Settings
dialog of the Spread Designer. To open this dialog, from the Settings menu, select an option under
the Spread Settings section. Each of the tabs in the dialog has a group of settings. To change the
setting, simply click in the edit field or select the choice. An example of the dialog is shown here.
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50 Spread Settings
E dit Scroll Bars | General | Split Box | Wiew | Titles
Settings
[ ] Allow Drag and Dirop [ ] Allow Users to Enter Formulas
[ ] Allow Drag and Fil Handle Clipboard F.eys [AutaClipboard]

Clipboard Optionz for Headers

() Mone () Copy/Paste Column Headers
() Copy/Paste Fow Headers (® Copy/Paste &l Headers
] 4 Cancel Help

When finished making changes on all tabs, click OK. If you wish to apply the changes from the active
tab, click Apply and then click on the next tab of settings to review or change.

This dialog has the following tabs:

Tab Description
Edit Tab (on- Change certain aspects of editing cells. Options to change include: Editing
line Text Can Overflow, Cells Always in Edit Mode, Editing Replaces Existing Text,

documentation) and On Focus Set Cell to Pointer.

Scroll Bars Tab  Set the alignment and display of scroll bars: Align at Last Row and Column,

(on-line Scroll Box Reflects Maximum Rows, Horizontal Scroll Bar Display
documentation)

General Tab Set options for controlling multiple features of the spreadsheet, such as the
(on-line ability to drag an drop or drag and fill a range of cells.

documentation)
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Split Box Tab Set the alignment and display of split boxes: Column Split Box Alignment,

(on-line Column Split Box Display, Row Split Box Alignment, Row Split Box Display.
documentation)

View Tab (on- Set various settings relating to the view: Cell Contents Can Overflow, Display
line Note Indicator, Retain Selected Block, Cell Buttons Display, Block Mode.
documentation)

Titles Tab (on- Set a Title and SubTitle for the control.
line
documentation)

For more information on settings related to user interaction, refer to Customizing Interaction in
the Overall Component (on-line documentation) in the Developer’s Guide. For more
information on the appearance settings of the Spread, refer to Customizing the Overall
Component Appearance (on-line documentation) in the Developer’s Guide.

For more details on the individual settings, refer to the properties of the FpSpread ('FpSpread
Class' in the on-line documentation) class.

Unhide Specific Row or Column Dialogs

You can display previously hidden rows or columns by unhiding them in the Spread Designer.
Right-click on a selected row. Select the Unhide menu option. Select the Specific Row dialog,
as shown in the figure. Right-click on a selected column to get the Unhide menu for a column.

<0 Unhide Specific Row

Pleaze enter the row number.

k. Cancel

For more details, refer to the Row ('Row Class' in the on-line documentation) class
Visible ('Visible Property' in the on-line documentation) property or the Column
('Column Class' in the on-line documentation) class Visible ('"Visible Property' in
the on-line documentation) property.

For more information on hiding parts of the sheet, refer to Showing or Hiding a Row or
Column (on-line documentation) in the Developer’s Guide.

Zoom Dialog
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You can determine the scaling of the display of the sheet. This does not effect scaling of the
printing of the sheet. To open the Zoom dialog in the Spread Designer, from the View menu,
select Zoom. The Zoom dialog appears as shown in the figure.

Zoom

M agrification

() 200
(® 1003
() 75%
() 50
() 25
() Fit zelection

() Custam 100 4

] Cancel

Select the zoom factor for increasing or decreasing the scaling of the display of the sheet.
Click OK when finished. The Fit Selection option will zoom the sheet view out to 400%
(fixed) and make the selected cell the upper, left cell.

For more information, refer to the ZoomFactor ('ZoomFactor Property' in the on-line
documentation) property of the FpSpread ('FpSpread Class' in the on-line
documentation) class.

To allow the user to set the scaling, refer to Allowing the User to Zoom the Display of the
Component (on-line documentation) in the Developer’s Guide.
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Spread Designer Editors

The editors of the Spread Designer provide a quick way of setting properties and customizing
specific aspects of your Spread component. There are editors specific to an object, such as a
sheet skin editor, a cells editor, a formula editor, and a border editor.

For more information on the individual editors, refer to the detailed description of each.

¢ Alternating Row Collection Editor
¢ Border Editor

e Cells, Columns, and Rows Editor
¢ DefaultGroupFooter Editor

e Formula Editor

¢ Focus Indicator Editor

¢ Grouplnfo Collection Editor

e Header Editor

e InputMap Editor

¢ Named Style Editor

e SheetSkin Editor

e SheetView Collection Editor

e Shortcut Collection Editor

¢ SmartPrintRule Collection Editor
e SpreadChart Collection Editor

¢ SpreadSkin Editor

e TabStrip Editor

For information on the other dialog boxes in the Spread Designer, refer to the Spread
Designer Dialogs.

Alternating Row Collection Editor

You can set colors for alternating rows with the AlternatingRow Collection Editor of the
Spread Designer. You can launch the AlternatingRow Collection Editor from the Spread
Designer by either

o selecting the sheet from the drop down on the right side of the designer and choosing
AlternatingRows under the Appearance section

o selecting the sheet in the data area and choosing AlternatingRows under the
Appearance section

The AlternatingRow Collection Editor appears as shown in this figure.
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AlternatingRow Collection Eclitor ?
Members: FarPoint. \win. 5 pread.AlkematingF aw properties;
l] FarPoint iin s pread AlternatingRgiFER £ |
1| FarPaint.\win.Spread.AlternatingR c =
4 Misc .
B ackCalar [ ]
Border [hioheE]
» CelPadding FarFoint. \win. Spread. CellP.
CelType [hioheE]
Font [hione]
ForeColar [ ]
Hornzontalslignment  General
[metd ode [nherit
ImeSentenceMode  Inhent W
BackColor
Gets or etz the background color for thiz alkermating
< 5 | | T,
] Cancel

Set the various properties as needed in the Misc area. When done, click OK.
Border Editor

You can place a border around a cell or range of cells using the Border Editor of the Spread
Designer. You can launch the Border Editor from the Spread Designer by either

¢ selecting the Home menu option, then the Border drop-down under the font
section, and then selecting More Borders...

o selecting cells in the data area, right-clicking, and selecting Borders

The Border Editor appears as shown in this figure.
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Shyle:

MHone ™

................ HairlinE

-------- Datted

'''' Drash Dot Dot

=== Dagh Dot

""""" Drazhed

— Thin

""" tedium Dazh Dot Dot
Slanted Dash Dot

= === Medium Dazh Dot

£ >

@ Border Editor
Frezets
MHaone Outhne Ihzide
Barder
N _I 1 L
Test Test
= - F
Text Text
= - T r

Calor:

Set the border by using one of the presetz or the individual barder side buttons after choozing a

lie ztyle and color.

The Presets allow you to select already-defined border locations. For the entire outer edge of a
range of cells, click Outline. For borders on all the edges of cells in a range except the outline,

ak.

Cancel Help

click Inside. To clear all the borders, click None.

In the Border area, click on the part of the cell where a border should appear. You do not see

82

anything in the Border area of this dialog until you select a line style, since None is the default.
Select the border line style and border line color in the Line settings area. When done, click OK.

For more information on the options for row or column size, refer to Customizing Cell
Borders (on-line documentation) and Customizing the Outline of the Component

(on-line documentation) in the Developer’s Guide. For more details on borders, refer to the

various border classes in the FarPoint.Win ('FarPoint.Win Namespace' in the on-line
documentation) assembly.

Cells, Columns, and Rows Editor
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You can customize the appearance of cells, columns or rows with the Cells, Columns, or
Rows Editor of the Spread Designer. This editor is launched from the Properties window by
selecting sheet in the drop-down box on the right side of the designer and then clicking on the
button for the Cells, Columns, or Rows property. You can also access this dialog from the Other
Settings section under the Settings menu. This figure shows the editor with a cell selected.

s Cells, Columns, and Rows Editor = B
Select cellls), column(s), or row(s]: Cell[0.0] Properties:
A E C A 4 Mizc ﬁ
1 BackColor [ ]
Border [hione)
- CanFocus True
3 »  CellPadding FarPoint.\wWin. Spreac
4 CelType [hione]
5 ColumnSpan |1
ErrorT et
B Font [hione)
I ForeCaolaor [ ]
! Forrnula
g Huorizontaltlignn General
[rmet ode [nherit
10 Irme5entencetd Inherit
11 [nputScope [nherit
12 Locked Falze il
13 BackColor
14 v Gets ar gets the background color for a cell.
< >
k. Cancel Help

This editor allows you to edit various properties associated with four objects. If a cell is selected,
the properties for the Cells ('Cells Class' in the on-line documentation) class are
displayed in the properties window of this dialog. If a column is selected, the properties for the
Columns ('Columns Class' in the on-line documentation) class are displayed in the
properties window of this dialog. If a row is selected, the properties for the Rows ('Rows
Class' in the on-line documentation) class are displayed in the properties window of this
dialog. If the corner cell (of the sheet, in the upper right corner) is selected, the properties for
the DefaultStyle class are displayed in the properties window of this dialog.

Typically, the value of the properties are kept when opening this editor. But there are some
settings that are changed (in order to allow you to edit them and work with the editor in
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general); these include making all the headers visible, even if you have them hidden by using
code, and allowing notes to be editable, even if you have that turned off. In this editor you can
set several settings relating to sorting, spans, notes, and other aspects of cells, columns, and
TOWS.

Click Apply to apply those settings to the cell or column or row, or range of any of these, in
Spread Designer.

For more information on the appearance of cells, columns, and rows, refer to Customizing
the Appearance of a Cell (on-line documentation) and Customizing the Row or
Column Appearance (on-line documentation) in the Developer’s Guide.

For more information about styles and default styles, refer to Creating and Applying a Style
for Cells (on-line documentation) in the Developer’s Guide.

For more information about header cells, refer to Header Editor.

For details about the properties of a cell, refer to the Cell ('Cell Class' in the on-line
documentation) class or the Cells ('Cells Class' in the on-line documentation) class.
For more information about properties of a column, refer to the Column ('Column Class' in
the on-line documentation) class or the Columns ('Columns Class' in the on-line
documentation) class. For more information about properties of a row, refer to the Row
('Row Class' in the on-line documentation) class or the Rows ('Rows Class' in the on-
line documentation) class.

DefaultGroupFooter Editor

You can use the DefaultGroupFooter editor to create a group footer. Use the Group by
Column option to select the group column to set the group information for. You can also
specify the formula type. Use the Formula property for the actual formula.

This editor is launched from the Properties window by selecting sheet in the drop-down box
on the right side of the designer and then clicking on the button for DefaultGroupFooter.
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DefaultGroupFooter Eclitor

Select cells) Group by Column

A : C b .0

1

Tag
Text

(¥
cell

1 MHumber of raws

Celli0.0] Properties:

4 Misc
AggregationFormal
AggregationType  Mone
ErrarText
Formula
Imetd ode
Ime5Sentencetdode Inherit
[nputScope
MHaote

ak.

- O X

[nherit

[nherit

AggregationFormat5tring
etz ar zets the aggregation farmat string in this

Cancel

The GroupFooterVisible property must be set to true to see the group footer and AllowGroup

and AllowColumnMove should be set to true to allow the user to group.

From the File menu choose Apply and Exit to apply your changes to the FpSpread

component and exit Spread Designer.

Formula Editor

You can enter a formula into a cell or range of cells using the Formula bar or the Formula Editor in the Spread
Designer. The Formula bar provides a quick way to enter a formula for a cell or group of cells. The Formula Editor
allows you to select any of the built-in functions and is called from the Formula bar when you click Equals, as shown

in the following figure.
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narme hox

(with cell coordinate) cancel

formula hox

Click Choose Formula (the equals sign button) or type equals (=) to begin the formula. This launches the Formula

B S — }( = =PRODUCT[SUM[AZ2:A5]52)
i i
apply choose
farmula  formula

L}

Function Category

Formula Editor

Function List
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Al

Date and Time
Engineering
Financial
|Hformnation
Logical

LDDkuE and Reference

Statiztical
Text

SUBTOTAL

SUMIF
SUMIFS
SUMPRODUCT
SUMSH
SUMe2MY2
SUM=2FY2
SUMehY2
TAMN

TANH

~

W

SUM[numberl, [number?], [number3], [numberd], ._.]

Sumg values, cellz, or blocks.

Farmula

0k

PRODUCT[SUMIAZAS).52)

Cancel

Apply

Editor. (You can also launch the Formula Editor by clicking the button in the Formula property in the Property
Window.) The Formula Editor gives you a list of the more than 200 built-in functions that you can use and displays a
brief description of the selected function. To choose a function, double-click on the function name and it appears in the

Formula field. Functions are organized by category. You may also type operators and constants to construct your
formula. For more information on formulas and functions, refer to the Formula Reference.

You can enter the formula in the Formula field in the Formula Editor or in the formula box in the Formula bar.

When you are done entering the formula with the Formula Editor, click Apply or OK. When you are done typing the
formula in the formula box, click Enter (the check mark button). This applies the formula to the selected cell or range of

cells.

To display or hide the formula bar, from the View menu, select Formula Bar.

From the File menu choose Apply and Exit to apply your changes to the FpSpread component and exit Spread
Designer.

Focus Indicator Editor

You can customize how the cell border appears when that cell is in focus using the Focus
Indicator Editor of the Spread Designer. You can launch the Focus Indicator Editor from
the Spread Designer by selecting the Focus Indicator icon from the Settings menu
(Appearance Settings section).

The Focus Indicator Editor appears as shown in this figure.
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@ Focus Indicator Editor

Prewview

Mmoo = L o —

Thickness: 1=

-

Clear Load Image... Heset aE. Cancel Help

Select the color or image by clicking Load Image and selecting a graphics file. Then select the
line thickness, which is in units of pixels. The box on the left shows the loaded image and the
Preview area on the right shows the appearance of that focus indicator. To clear the image or
reset the settings, click the appropriate button. When done click OK.

For more details on focus indicator renderer classes, refer to the various classes in the
FarPoint.Win.Spread ('FarPoint.Win.Spread Namespace' in the on-line
documentation) assembly.

Grouplnfo Collection Editor

You can set basic formatting for groups with the GroupInfo Collection Editor of the Spread
Designer. You can launch the GroupInfo Collection Editor from the Spread Designer by
either

o selecting the sheet from the drop down on the right side of the designer and choosing
GrouplInfos under the Misc section

e selecting the sheet in the data area and choosing GroupInfos under the Misc
section

The GroupInfo Collection Editor appears as shown in this figure.
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Grouplnfo Collection Editor ?
Members: FarPaoint. \win. Spread. Grouplnfo properties;
+ =2
4+ 4 Misc -h
B ackCalor [ ] white
> Border LineBorder
Font [nione)
FooterBackColor [ "wWhite
 FooterBorder LineBorder
FooterFant [hione)

FooterForeColor [ SteelBlue
FooterHarizontal Left
Footerferticaldlic Center

| Y o P | T [ T

BackColor

Gets ar zets the background color of the
grouping information.

Add REemowve

k. Cancel

Click Add and then set the various properties as needed in the Misc area. When done, click
OK.

Header Editor

You can customize the headers of rows or columns using the Header Editor. To launch the
Header Editor in Spread Designer, select a header cell or cells, right-click, and select
Headers. The Header Editor appears as shown in this figure.

Copyright © GrapeCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide 89

@ Header Editor

Apply to Column D
Fiow index within column I
Height 20

<Default:

B ackCalar [ | Control A
»  Border BevelBorder

CanFocus True

CelType [hioneE]

ColumnS pan 1

ErrorText

Font [hioreE]

ForeColar Bl ControlText

Farmula b
BackColor

Gets or sets the background color for a cell.

] Cancel Help

The Header Editor lets you specify the text in the header of a particular row or column or
range of row or columns. If more than one header is selected, from the Apply to Column field
(or Apply to Row field), select a header. If you have a multiple-row column header (or a
multiple-column row header), select the column (or row). Set the height in pixels. In the
property list, select or type the properties you wish to set, and the preview window shows the
header as it appears when you click the Apply button. You can click Apply to add the settings to
the selected header cell and keep the editor open so that you can select more headers. When
done, click OK.

For more information on customizing headers, refer to Customizing the Appearance of
Headers (on-line documentation) in the Developer’s Guide. For more details on managing
the headers in code, refer to the ColumnHeader ('ColumnHeader Class' in the on-line
documentation) and RowHeader ('RowHeader Class' in the on-line
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documentation) classes.

InputMap Editor

920

You can create input maps with the InputMap Editor in the Spread Designer. You can launch the InputMap Editor
from the Spread Designer by selecting Input Map under the Settings tab. The input map icon is located in the Other
Settings section of the Settings tab.

The InputMap Editor appears as shown in the following figure.

@

Select Inputtdap

(@ Select by Operation and Inputtd ap Mode

Operation Mode | Marmal b
Inputhap Mode |y herFocuzed W
() Select Input Map WhenShapeH asFocus
Shortcut Key
() Select by Keyboard
(®) Select from List
LB uttarn v
] el [ Shitt [ Al
Achion
Achion Description "
Maone Dioes not perform
StartE diting Turnz on edit moc
StartE ditingFarmula Allowes the uzer to
ClipboardCut Cutz the zelected

ClipboardCutD atalnly
ClipboardCuttzString
£

[ Show all actions

Cutz only the dats
Cutz the selected
>

Load Input Maps...

Inputtdap Editor

Current Setting

Fey

Back
Enter
Dempluz
Ctl+C
Chil +%
Chl + =
Cl + Inz
Shift + Diel
Shift + Ins
Fd
Shift + Space
Ctl+2
Chl +

Save

Action

StartE diting

StartE diting

StartE ditingForrmula
ClipboardCopy
ClipboardPasteall
ClipboardCut
ClipboardCopy
ClipboardCut
ClipboardPasteall
ShowS ubE ditor

SelectHow
Indo
Redo
>
Prewviegw » >
Cancel Help

Select the mode and then specify any keys and actions. Use the Add button to add the new input map to the current
input map list. Select OK when finished.

You can also save and load input maps to an XML file. The Preview button allows you to preview changes in the

designer.

To specify a key using the "Select by Keyboard" option, click in the text box and press the key. For example, hold the
"Ctrl" key and press the "D" key, and the keystroke is: Ctrl + D. The button "Select by Keyboard" is then checked

automatically.
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Named Style Editor

You can customize the appearance of cells by defining a named style. You can do this within the
Spread Designer using the NamedSyle Collection Editor. This editor is launched from the
Properties window by first selecting the Spread and then clicking on the button in the
NamedStyle property. This property is under the Appearance section. This figure shows the
editor with a named style added.

MamedStyle Collection Eclitor ?
Members: Stylel properties:
+ =2
4+ > CellPadding FarPoint.Win.5pre ~
CellType [nione)
Font [hione)
ForeColaor [ ]
Huorizontaldlignm General
IrmeM ode [nherit
ImeSentenceta [nherit
[nputScope [rherit
Locked Falze
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k. Cancel

This editor allows you to edit various properties associated with a style that you define. Click
Add to start a new style and define the properties of that style, including the name. When you
are done, click OK.

For more information about styles and default styles, refer to Creating and Applying a Style
for Cells (on-line documentation) in the Developer’s Guide.

For details about the properties of a style, refer to the NamedStyle ('NamedStyle Class' in
the on-line documentation) class.

SheetSkin Editor
Yon can enstomize the skin. the collection of annearance settinos. for the sheet with the SheetSkin Editor of the
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Spread Designer. To launch the Sheet Skin Editor, from the Settings menu (Appearance section), select the
SheetSkin Editor icon. Or from the Properties window with the sheet selected, in the Appearance category, select
ActiveSkin and click on the button. The SheetSkin Editor appears with the Default skin selected. This figure shows a
particular skin selected to illustrate the preview of that skin.
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Cancel Apply Help

The left side of the editor allows you to choose the skin, and the right side shows a preview of the appearance before you
apply it to the sheet. The first tab, Pre-Defined, lists the built-in skins that are already available and ready to use and
customize. You can simply click on a skin name and see a small sample of the appearance in the Preview area. The
second tab, Saved, lists any saved custom skins that are available. This shows any files that you have saved. You can
then preview that skin and either customize it further or apply it as is. The third tab, Custom, allows you to create your
own custom skin or customize either one of the pre-defined skins or a skin loaded from a file.

Click Apply to apply that skin with all its appearance settings to the sheet in Spread Designer.

For more information about adding a new custom skin, refer to Creating a Custom Skin for a Sheet (on-line
documentation) in the Developer’s Guide.

For more information on loading and saving skins as files, refer to Saving and Loading a Skin (on-line
documentation) in the Developer’s Guide.

For details about the properties of a skin, refer to the SheetSkin ('SheetSkin Class' in the on-line
documentation) class.

SheetView Collection Editor
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You can customize the collection of sheets with the SheetView Collection Editor of the
Spread Designer. To launch the SheetView Collection Editor, select the Spread (from the
selection drop-down list, select Spread), and in the Properties window with the Spread
selected, in the Data category, select Sheets and click on the button. The SheetView
Collection Editor appears. This figure shows the editor with one sheet.

SheetView Collecion Editor ?
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The left side of the editor allows you to see the list of sheets in the collection. You can click Add
or Remove to add more sheets or remove specific sheets. Navigation arrows in the middle of
the editor let you move up and down the list of sheets.

The right side lists the Properties window for the sheet selected in the members list.

Click OK when done setting the properties for the sheets and when done adding or removing
sheets.

For details about the properties of a collection of sheets, refer to the SheetViewCollection
('SheetViewCollection Class' in the on-line documentation) class.

Shortcut Collection Editor
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You can use the Shortcut Collection Editor to map keys to actions for the GeTextBox and
the GeDateTime cells.

This editor is launched from the Properties window after selecting a GeDateTime or
GcTextBox cell in the work area and then selecting ShortcutKeys under the CellType

property.

The available actions depend on the cell type that is selected. The following image displays the
editor for a GeTextBox cell.

Shortcut Collection Editor
Shoartcuts: GcShorkout key
Shortcut key Actian (@ Keyboard input

Fe ShortcutClear

() Select shortcut key
Clear

Action:

=I-4a% Comman "~
----- ¥ ApplyRecommendedy al.

----- =% DropDown/Clozellp
----- " InputMewline
----- A% MextCel

----- A FPresiousCell v
< >

ak. Cancel

Select a shortcut key and an action. Use the Add button to add the mapped action and the
Remove button to remove mapped actions. The Clear button clears all the mapped actions.
Select OK to apply the changes.

SmartPrintRule Collection Editor

You can customize smart print with the SmartPrintRule Collection editor.

This editor is launched from the Properties window by selecting sheet in the drop-down box
on the right side of the designer, selecting PrintInfo, and then clicking on the button for
SmartPrintRules collection.
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SmartPrnintRule Collection Eclitor ?
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The left side of the editor allows you to see the list of rules. You can click Add or Remove to
add more rules or remove specific rules. Navigation arrows in the middle of the editor let you
move up and down the list of rules.

The right side lists the Properties window for the rule selected in the members list.
Click OK when done.

SpreadChart Collection Editor

You can use the SpreadChart Collection editor to create charts. You can set the appearance,
labels, plots, and many other chart properties. For more information on charts in general, refer
to Working with the Chart Control (on-line documentation).

This editor is launched from the Properties window by selecting sheet in the drop-down box
on the right side of the designer and then clicking on the button for Chart collection.
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SpreadChart Collection Eclitor ?

SpreadChart1 properties:

+ =2
4+ » ContexttenuStn L
Locked Falze
SizeProportional Falge
4 Data

> CategoreFarmula
ChartM are SpreadChart1

» DataFormula

» DataSetting Zemn, Hide hidden dal
Formula

» Model FarPoint. Win_Chai v

| Iy N [ p

Model
etz or sets the chart maodel.

Add - REemowve

k. Cancel

Use the Add button to add a chart type. The left side of the editor allows you to see the list of
charts. You can click Add or Remove to add or remove charts. Navigation arrows in the
middle of the editor let you move up and down the list of charts.

The right side lists the Properties window for the chart selected in the members list.

Click OK when done.

SpreadSkin Editor

You can customize the skin, the collection of appearance settings, for the entire control with the SpreadSkin Editor of
the Spread Designer. To launch the SpreadSkin Editor, from the Settings menu (Appearance section), select the
SpreadSkin Editor icon. Or from the Properties window with the spread selected, in the Appearance category, select
Skin and click on the button. The SpreadSkin Editor appears with the Default skin selected. This figure shows a
particular skin selected to illustrate the preview of that skin.
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The left side of the editor allows you to choose the skin, and the right side shows a preview of the appearance before you
apply it to the sheet. The first tab, Pre-Defined, lists the built-in skins that are already available and ready to use and
customize. You can simply click on a skin name and see a small sample of the appearance in the Preview area. The
second tab, Saved, lists any saved custom skins that are available. This shows any files that you have saved. You can
then preview that skin and either customize it further or apply it as is. The third tab, Custom, allows you to create your
own custom skin or customize either one of the pre-defined skins or a skin loaded from a file.

Click Apply to apply that skin with all its appearance settings in the Spread Designer.

For more information about adding a new custom skin, refer to Creating a Custom Skin for a Sheet (on-line
documentation) in the Developer’s Guide.

For more information on loading and saving skins as files, refer to Saving and Loading a Skin (on-line
documentation) in the Developer’s Guide.

For details about the properties of a skin, refer to the SpreadSkin class.
TabStrip Editor

You can customize how the tab strip appears by using the TabStrip Editor of the Spread
Designer. You can launch the TabStrip Editor from the Spread Designer by selecting the
TabStrip icon from the Settings menu (Appearance section).
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The TabStrip Editor is shown in the following figure. The TabStripPolicy has been set to
Always in this image (default setting is As Needed).
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The TabStripPlacement option allows you to place the tab strip at the top, bottom, or with
the horizontal scrollbar. The TabStripPolicy drop-down sets whether the sheet tabs are
displayed all the time, when needed, or not at all. The TabStripRatio sets the width of the tab
strip expressed as a percentage of the overall horizontal scroll bar width. You can also set the
backeolor and set colors and fonts for the active or default tabs. When done click OK.

For more details on focus indicator renderer classes, refer to the various classes in the
FarPoint.Win.Spread ('FarPoint.Win.Spread Namespace' in the on-line

documentation) assembly.
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Designing in the Data Area

Spread Designer helps you design your Spread component by letting you see most of the
settings you make at the time you make them, and by letting you access settings that you cannot
access in Visual Studio at design time. You can use Spread Designer for many aspects of design,
including customizing the appearance of your component. You can also load data into the
sheets in your component, if you want to do so. The Spread Designer lets you work with the
design in a data area that simulates the actual spreadsheet. By selecting items and changing
properties, you can see the result immediately in the data area.

The following topics describe some specific tasks you need to do in Spread Designer to
customize the FpSpread component by selecting part of the spreadsheet and changing the
properties either in the Properties window or a dedicated dialog.

¢ Selecting an Item in the Spread Designer

o Setting Properties in Spread Designer

¢ Entering a Formula in Spread Designer

¢ Adding and Customizing Sheets

For more information on the dialogs and editors, refer to the Spread Designer Dialogs and
Spread Designer Editors.

For more information on working with the design once you have completed it, refer to
Working with the Design.

Selecting an Item in the Spread Designer

To set the properties for something in Spread Designer, you need to select the object with which
you want to work, then set the properties for it. For example, to set property for a cell, you must
select the cell, then set properties in the properties list or from the right-click menu. There are
different ways to select items and there are different properties available for customizing based
on the item selected.

You can tell what object is currently selected by looking at the status bar. For information on
how to interpret the notation in the status bar, refer to the Spread Designer Status Bar.

These are several items that can be selected in the Spread Designer.

¢ Selecting an Individual Cell

¢ Selecting the Cells with Data

¢ Selecting a Contiguous Range of Cells

¢ Selecting a Row of Cells

¢ Selecting a Column of Cells

¢ Selecting a Sheet of Cells

¢ Selecting an Entire FpSpread Component
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For more information on setting properties of the selected item, refer to Setting Properties
in Spread Designer.

Note: If you are trying to work with an object, and the properties for the object do not appear
to be correct, or your choices do not appear to have an effect, make sure you have selected the
object with which you intend to work.

For more tasks in Spread Designer, return to Designing in the Data Area.
Selecting an Individual Cell

You can select an individual cell in the data area by clicking on the cell. The active cell shows the
focus indicator and displays the cell with the sheet background color, in this case white.

A, B C D

1
2
3
4

All cell types (check box, button, etc.) do not react to the first click on cell selection. This allows
the Spread Designer to set the selected cell(s) into the Properties window for property access.
You must double-click a cell for a change to occur; simply single clicking does not change the
state of the button or the state of edit mode.

For information on how to set properties for a cell, refer to Setting Cell Properties in
Spread Designer.

For information on other selectable items, return to Selecting an Item in the Spread
Designer.

Selecting the Cells with Data

You can select all the cells in the data area that have data in them by right clicking anywhere in
the data area and selecting "Select All > Data" from the context menu. The active cell still
remains whichever was the last active cell, but now all the cells with data are shown as selected.
An example of this is shown in the figure, with the cells that have data appearing in light blue.
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Now you can perform operations on the entire selection of cells with data. The possible
operations are available from the context menu by right clicking on one of the selected cells.
These include the Clipboard operations of cut, copy, and paste, setting the cell type, setting the
cell border, and clearing the contents.

If the cells with data are not contiguous, then you cannot lock or span cells, but these options
are also available from the right click menu.

For information on other selectable items, return to Selecting an Item in the Spread
Designer.

Selecting a Contiguous Range of Cells

You can select a range of cells and set properties for all the cells in that range. To select a cell or
range of cells, click and drag over the cells in the work area. The Spread Designer shows the
cells are selected by highlighting them. The active cell shows the focus indicator and displays
the cell with the sheet background color, in this case white.
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Not all cell types (check box and button for instance) react to the first click on cell selection.
This allows the Spread Designer to set the selected cell(s) into the Properties window for
property access. You must double-click a cell for a change to occur; simply single clicking does
not change the state of the button or the state of edit mode.

For information on other selectable items, return to Selecting an Item in the Spread
Designer.

Selecting a Row of Cells

You can select a row and set properties for all the cells in that row. To select a row or column,
click on the header in the work area as if you are in a spreadsheet. The selected row is
highlighted as shown here.
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Also, you can add or remove rows or columns by using the options in the right-click menu. The
Spread Designer shows the row or column is selected by highlighting all the cells in that row or
column.

Note: There is a difference between a row (or column) locked and a cell locked; the toolbar
buttons and context menu selections represent the status of the row, column, or cell selected.
Having the Locked property set for a row is different than having it set for a cell in that row.

For information on how to set properties for a row of cells, refer to Setting Row Properties
in Spread Designer.

For information on other selectable items, return to Selecting an Item in the Spread
Designer.

Selecting a Column of Cells

You can select a column of cells and set properties for all the cells in that column. To select a
row or column, click on the header in the work area as if you are in a spreadsheet. The selected
column is highlighted as shown here.
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Also, you can add or remove rows or columns by using the options in the right-click menu. The
Spread Designer shows the row or column is selected by highlighting all the cells in that row or
column.

Note: There is a difference between a row (or column) locked and a cell locked; the toolbar
buttons and context menu selections represent the status of the row, column, or cell selected.
Having the Locked property set for a row is different than having it set for a cell in that row.

For information on how to set properties for a column of cells, refer to Setting Column
Properties in Spread Designer.

For information on other selectable items, return to Selecting an Item in the Spread
Designer.

Selecting a Sheet of Cells

If you want to set properties for a sheet, you must select the sheet by clicking the sheet tab. Or you can select Sheet from
the selected item list as illustrated in the figure below. In this figure, the sheet named Sheet1 is selected as the current
object.
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You can select all the cells in the sheet (not the headers) by using Home > Select All > Cells

You can select all the cells in the sheet that have data in them by using Home > Select All > Data.

To select the entire sheet, you can click on the sheet corner in the upper left area of the work area of the spreadsheet.
This selects and highlights all the cells (corner, headers, and data area cells) in the sheet. You can also select the sheet
from the selection box in the Properties window (above the list of properties).

Copyright © GrapeCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide 106

For information on how to set properties for a sheet, refer to Setting Sheet Properties in Spread Designer.

For information on other selectable items, return to Selecting an Item in the Spread Designer.
Selecting an Entire FpSpread Component

To select the entire FpSpread component, you can only select it from the selection box in the
Properties window (above the list of properties). This selects the entire component. Nothing is
shown in the display other than the word “Spread” that appears in the Status Bar.

For information on other selectable items, return to Selecting an Item in the Spread
Designer.

Setting Properties in Spread Designer

There are several ways to set the properties of the spreadsheet component or of any of its
objects, using the Spread Designer. Most involve first selecting an item.

For a list of what can be selected, refer to Selecting an Item in the Spread Designer.

In general, with the item selected, these are the ways you can set properties for that selected
item.
e Use the Properties window and select or type in the setting for the property

e Use the menus to select either Sheets, Rows, or Columns and open a dialog or
editor to set properties for that item

e Right-click, and use the context (pop-up) menu to set some of the properties, typically
by selecting a choice that opens a dialog or editor

For more information on specific items that can be selected and how to set properties for those
items, refer to these:

¢ For an entire sheet of cells, refer to Setting Sheet Properties in Spread
Designer.

e For a column of cells, refer to Setting Column Properties in Spread Designer.
e For a row of cells, refer to Setting Row Properties in Spread Designer.

e For a cell or range of cells, refer to Setting Cell Properties in Spread Designer.
e For a table, refer to Setting Table Properties in Spread Designer.

For more information on using the dialogs and editors, refer to Spread Designer Dialogs
and Spread Designer Editors.

The properties window corresponds to the properties of a cell or sheet or component. It does
not apply to shapes, which are on a separate layer. To change properties of a shape, right-click
on a shape and select Properties or use the Drawing Tools menu. For more information on
shapes, refer to Designing Shapes.

For more tasks in Spread Designer, return to Designing in the Data Area.
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Setting Sheet Properties in Spread Designer

You can set properties on an entire sheet of cells and those properties apply to the sheet.

Here is the context menu available to a selected sheet. Right-click on a selected sheet in the
designer to bring up this menu.

Clear |

Select All k Sheet
Lock m Cells
Sheet Settings... Data

Print Settings...
SheetSkin Editar...

FpSpreadSkin Editor...

This context menu has the following items:

Context
Menu
Choice

Clear

Select All

Lock

Sheet Settings

Print Settings

SheetSkin

Editor

FpSpreadSkin

Description and Reference

Removes the contents of all the cells in the selected row but does not affect
the header cells.

Allows you to select the entire sheet, all the cells in the data area, or all the
cells with data.

You can lock a column of cells so that the user cannot edit them. Remember
this applies the lock to the column, not the individual cells.

Allows you to edit the properties for the entire sheet. For more information,
refer to Sheet Settings Dialog.

Allows you to edit the printing properties for the entire sheet. For more
information, refer to Sheet Print Settings Dialog.

Runs the SheetSkin Editor to allow you to edit the look and feel (skin) of the
entire sheet. For more information, refer to SheetSkin Editor.

Runs the FpSheetSkin Editor to allow you to edit the look and feel (skin) of
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Editor the entire control. For more information, refer to SpreadSkin Editor.

For information on how to select a sheet, refer to Selecting a Sheet of Cells.

For information on other selectable items, return to Setting Properties in Spread
Designer.

Setting Row Properties in Spread Designher

You can set properties on a row of cells and those properties apply to the row. You can work
with either rows or columns selected to speed the work in customizing cells in the data area.
With the row (or rows) or column (or columns) selected, use the context menu by right-clicking
on the selected area to perform some actions on the cells in that row or column quickly. For
example you can select a cell type for the cells, you can insert or delete a row or column, and you
can set the row height or column width.

With a row selected (and this is similar to that for a column selected), you can perform any of
these operations available from the context menu. Here is the context menu available for
selected rows.

Cell Types *

Cut

Capy

Paste »

Insert...

Delete...

Clear

Select All L\5 3 Sheet
Cells
Data

Eow Height...

AutoFit

Hide

Unhide b
Lack

Headers...

This context menu has the following items:
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Context Description and Reference

Menu
Choice

Cell Types
Cut, Copy,
Paste
Insert
Delete
Clear
Select All
Row
Height
AutoFit
Hide /
Unbhide

Lock

Headers

You can select the cell type for the cells in this row. For more information, refer
to Cell Type Dialog.

In this release the copy, cut, and paste options are not available. Any Clipboard
operation would have to be done in code.

This allows you to insert a row or rows above the selected row. See the Row or
Column Insert or Delete Dialogs.

Allows you to delete a row or rows, but not without first asking you to confirm.
See the Row or Column Insert or Delete Dialogs.

Removes the contents of all the cells in the selected row but does not affect the
header cells.

Allows you to select the entire sheet, all the cells in the data area, or all the cells
with data.

Set the height of the entire row. See the Row Height or Column Width
Dialog.

Automatically sizes the row to fit the contents by adjusting the row height.
With Hide, make the row invisible to the user, though still accessible by code. To
make it visible again, use Unhide. When you hide a row, the data is kept in the

data model, but the row is not displayed in the sheet.

You can lock a row of cells so that the user cannot edit them. Remember this
applies the lock to the row, not the individual cells.

Runs the Header Editor to allow you to edit the header of this row. For more
information, refer to Header Editor.

For information on working with a column of cells, refer to Setting Column Properties in
Spread Designer.

For information on other selectable items, return to Setting Properties in Spread

Designer.

For information on how to select a column, refer to Selecting a Row of Cells.
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For more tasks in Spread Designer, return to Designing in the Data Area.
Setting Column Properties in Spread Designer

You can set properties on a column of cells and those properties apply to the column. You can
work with selected columns to speed the work in customizing cells in the data area. With the
column (or columns) selected, use the context menu by right-clicking on the selected area to
perform some actions on the cells in that column quickly. For example you can select a cell type
for the cells, you can insert or delete a column, and you can set the column width.

With a column selected (and this is similar to that for a row selected), you can perform any of
these operations available from the context menu. Here is the context menu available to
selected columns.

Cell Types »

Cut

Copy

Paste k
Insert...

Delete,..

Clear

Select All 3 Sheet

% Cells

Data

Column Width...

AutoFit

Hide

Unhide b
Lock

Headers...

This context menu has the following items:

Context Description and Reference
Menu
Choice

Cell Types You can select the cell type for the cells in this column. For more information,
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refer to Cell Type Dialog.

Cut, Copy, In this release the copy, cut, and paste options are not available. Any Clipboard

Paste operation would have to be done in code.

Insert This allows you to insert a column or columns to the left of the selected column.
See the Row or Column Insert or Delete Dialogs.

Delete Allows you to delete a column or columns, but not without first asking you to
confirm. See the Row or Column Insert or Delete Dialogs.

Clear Removes the contents of all the cells in the selected column but does not affect
the header cells.

Select All  Allows you to select the entire sheet, all the cells in the data area, or all the cells
with data.

Column Set the width of the entire column. See the Row Height or Column Width

Width Dialog.

AutoFit Automatically sizes the column to fit the contents by adjusting the column
width.

Hide / With Hide, make the column invisible to the user, though still accessible by

Unhide code. To make it visible again, use Unhide. When you hide a column, the data is
kept in the data model, but the column is not displayed in the sheet.

Lock You can lock a column of cells so that the user cannot edit them. Remember this
applies the lock to the column, not the individual cells.

Headers Runs the Header Editor to allow you to edit the header of this column. For more

information, refer to Header Editor.
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For information on working with a row of cells, refer to Setting Row Properties in Spread
Designer.

For information on other selectable items, return to Setting Properties in Spread
Designer.

For information on how to select a column, refer to Selecting a Column of Cells.

For more tasks in Spread Designer, return to Designing in the Data Area.

Setting Cell Properties in Spread Designer
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These are some additional notes about setting properties of cells in particular. There are several
ways to set the properties of an individual cell in the Spread Designer. The first step is selecting
a cell. (For information on selecting a cell, refer to Selecting an Item in the Spread
Designer.)

If you are setting cell types for a given cell or range of cells, use the cell types right-click menu or
the Cell Types option in the Home menu to quickly apply the cell type. In the Cell Types
option, there is a separate button or icon for each cell type.

When you set a cell to be a Label cell, the cell becomes locked. If you then clear this cell so that
it is no longer a Label cell, the Locked property is still set, so you need to unlock these cells to
reset them completely.

With a range of cells selected, you can perform any of these operations available from the
context menu.

" Cell Types *

Cut
Capy

Paste k

Clear

Select All k

Span
Lock

Barders...

This context menu has the following items:

Context Description and Reference
Menu Choice

Cell Types You can select the cell type for the cells in this row or column. For more
information, refer to Cell Type Dialog.

Cut, Copy, Paste These Clipboard operations handle the contents of the cells and cut,
copy, and paste as expected.

Clear Removes the contents of all the cells in the selected row or column but
does not affect the header cells.
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Select All Allows you to select the entire sheet, all the cells in the data area, or all
the cells with data.
Span Automatically sizes the row or column to fit the contents by adjusting

either the row height or column width.

Lock You can lock a row and column of cells so that the user cannot edit
them.
Borders Runs the Border Editor to allow you to edit the borders of the cells. For

more information, refer to Border Editor.

For information on putting a formula in a cell, refer to Entering a Formula in Spread
Designer.

For information on how to select a cell, refer to Selecting an Individual Cell. For

information on how to select a range of cells, refer to Selecting a Contiguous Range of
Cells.

For more tasks in Spread Designer, return to Designing in the Data Area.
Setting Table Properties in Spread Designer

You can set properties for the table using the context menu.

Right-click on the table to display the context menu.
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3 1

g 11

G hy
Cell Types *
Cut
Copy
Paste 3
Clear
Select 4l 3
Span
Lock
Borders...
Tabkle 3
Insert 3
Delete k
Select k

This context menu has the following items:

Context Description

Menu Choice

Cell Types You can select the cell type for the selected item. For more information,
refer to Cell Type Dialog.

Cut, Copy, and These Clipboard operations cut, copy, and paste the selected item.
Paste

Clear Clears the selected item.

Select All Selects the sheet, cells, or data.

Span Automatically sizes the row or column to fit the contents by adjusting either
the row height or column width.

Lock Locks the selected item.

Borders Displays the Border Editor to allow you to edit the borders of the cells. For
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more information, refer to Border Editor.

Table Adds a totals row or converts to a range.

Insert Adds columns or rows to the table.

Delete Removes columns or rows from the table.

Select Selects the table column data, entire table column, or table row.

Entering a Formula in Spread Designer

You can enter a formula into a cell or range of cells using the Formula bar and the Formula Editor in the Spread
Designer. The Formula bar provides a quick way to enter a formula for a cell or group of cells. The Formula Editor
allows you to select any of the built-in functions and is called from the Formula bar when you click Equals, as shown in
the following figure.

o Formula Editor
name box . Function Category Function List
(with cell coordinate) cancel formula box
| | Al SUBTOTAL ~
t = - Date and Time
| ER - (3 .,J » = =PRODUCT[SUM[AZ:45].52] Engineering SUMIF
| | Financial SUMIFS
apply choose |Hformnation SUMPRODUCT
Logical SUMSO
formula farmula Lookup and Fieference | | SUMX2MY2
FIETATRNN | SUMCRY?
Statigtical SUMEMY2
Text TAM
TANH v

SUM[numberl, [number?], [number3], [numberd], ._.]

Sumg values, cellz, or blocks.

Formula | PRODUCT[SUM[AZAS]SZ]

0k Cancel Apply

Click Choose Formula (the equals sign button), which launches the Formula Editor, or type equals (=) to begin
entering the formula. (You can also launch the Formula Editor by clicking the button in the Formula property in the
Property window.) The Formula Editor gives you a list of the built-in functions that you can use and displays a brief
description of the selected function. To choose a function, double-click on the function name and it appears in the
Formula field. Functions are organized by category. You may also type operators and constants to construct your
formula.

You can enter the formula in the Formula field in the Formula Editor or in the formula box in the Formula bar.
When you are done entering the formula with the Formula Editor, click Apply or OK. When you are done typing the
formula in the formula box, click Enter (the check mark button). This applies the formula to the selected cell or range of
cells. When you click OK or Apply, the Formula Editor evaluates the formula to see if it is a valid formula. If it is not
valid, it displays an error message. For more information on formulas and functions, refer to the Formula Reference.

To display or hide the formula bar, from the View menu, select Formula Bar.
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From the File menu choose Apply and Exit to apply your changes to the FpSpread component and exit Spread
Designer.

For more tasks in Spread Designer, return to Designing in the Data Area.
Adding and Customizing Sheets

In Spread Designer, you can take advantage of multiple sheets. You can add sheets, name
sheets, and customize the appearance of sheets. This involves using the Sheet Editor, which is
described in detail in SheetView Collection Editor.

By default, the component has one sheet, named Sheet 1 and referenced as sheet index 0, but
allows multiple sheets. You can add and remove sheets in the Spread Designer.

To add a sheet, click add in the SheetViewCollection editor. You can also click on the new
sheet icon in the sheet tab area. A new sheet named Sheetn (where n is an integer) is added to
the component.

If you want to change the name of the new sheet, with the new sheet as the active sheet, in the
property list in the Appearance category, change the SheetName property. Or simply double-
click on the sheet name tab, and edit the sheet name in the text box.

To remove a sheet, from the SheetView Collection editor, select remove.

You can name the sheets or use the default sheet names. The default sheet name is "Sheet1" and
as other sheets are added, the sheet are named incrementally "Sheet2", "Sheet3", etc. The next
name is always the least number sheet available; for example if Sheet2 is removed but Sheet3
exists, adding a sheet creates a sheet named Sheet2. Subsequent sheets are Sheety, etc.

For information about adding and customizing sheets in code, refer to Working with
Multiple Sheets (on-line documentation) in the Developers Guide.

For information about the display of the sheet names in the sheet name buttons, refer to
Customizing the Sheet Name Tabs of the Component (on-line documentation) in
the Developers Guide.

For more tasks in Spread Designer, return to Designing in the Data Area.
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Working with the Design

Once you are done creating the design in Spread Designer, and you have made all the changes
necessary, there are several operations you can perform with that design. These topics describe
how to work with the design.

These topics describe the operations you can perform with the design in the Spread Designer.

e Applying the Design to the Form

¢ Resetting and Clearing Design Work

¢ Saving and Opening Design Files

¢ Previewing a Sheet in Spread Designer
e Printing a Sheet from Spread Designer

Applying the Design to the Form

When you have finished setting the properties you want to set in Spread Designer, you can
apply your changes to the FpSpread component, and then either continue to work in Spread
Designer or close Spread Designer.

When you are ready to apply your changes, you can apply all of your changes, just the
formatting changes you have made (such as setting the cell types for cells), or just the data
changes you have made.

To apply your changes, do one of the following:

e From the Spread Button (File menu icon) choose Apply.

e From the Spread Button (File menu icon) choose Apply and Exit to apply all your
changes and exit Spread Designer.

e From the Spread Button (File menu icon) choose Exit Spread Designer or click the
Close button. Spread Designer then confirms if you want to apply the changes you
have made in Spread Designer. If you select Yes, all changes are applied to the
component.

For more tasks in Spread Designer, return to Working with the Design.
Resetting and Clearing Design Work

There are several ways of resetting, reverting, and otherwise clearing settings in Spread
Designer. If you have made changes in Spread Designer that you do not want to apply, and you
want to continue to work in the Spread Designer, you can reset all the sheet setting, you can
revert to when Spread Designer was opened, or you can clear certain cells.

To revert to the original settings that were in the FpSpread component at the time you opened
Spread Designer, from the Spread Button (File menu icon) choose Revert, then click Yes in
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the confirmation dialog. The component in Spread Designer is restored to the settings that were
in the component at the time you opened Spread Designer. This action is not available if you are
running Spread Designer stand-alone (outside of a development environment). This removes all
the settings, including data, that were added after you opened the Designer.

To reset all the settings in the Spread Designer, including deleting all the data in the
component, from the Spread Button (File menu icon) choose New, then click Yes in the
confirmation dialog. The component in Spread Designer then has all properties for all objects
set back to their default values, and all data is removed, and all sheets beyond the first one are
removed. For more information on resetting items, refer to Setting and Resetting User
Interaction (on-line documentation). This does not affect the preference settings for
working with the Spread Designer, only the data and settings for the component being
designed.

To clear the cells, select the cells and from the context menu, select Clear. This removes the
data and formatting from those cells.

For more tasks in Spread Designer, return to Working with the Design.
Saving and Opening Design Files

When you have finished designing a Spread, you can save the file to either a Spread XML file or
a BIFF-compatible file. From the File menu icon, select Save or Save As New and specify a
file name and location.

To open an existing file, from the File menu, select Open and select the file from the File
dialog, or select a file under the Recent Documents section.

For saving Spread Designer to an XML file, the Spread element contains these elements

e Data
e Drawing
e Presentation
e Settings
o Style
For more information on the save and open options from the File menu, refer to File Menu.

For details of what is exported to the BIFF-compatible file, refer to the Import and Export
Reference (on-line documentation).

If you are using Spread Designer as a stand-alone application, you can save your work to a file
before closing Spread Designer. To best preserve all the settings you have created in Spread
Designer, save to a Spread XML file when using Spread Designer stand alone.

For information on saving and loading files in general, refer to the Managing File
Operations (on-line documentation) in the Developer’s Guide.

For more tasks in Spread Designer, return to Working with the Design.
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Previewing a Sheet in Spread Designer

To see what the effects of any changes with Spread Designer would be at run time, you can preview the
spreadsheet before saving an applying the changes to the spreadsheet. From the File menu icon, select
Preview, and a separate window opens with the spreadsheet as it would appear at run time. This Preview
window has all the changes you have made Spread Designer and allows you to test those changes before saving
and applying them.

@ )~ [ ._j H GrapeCity Spread Designer [MET 2.0 Framew:
o o |
LT Apply " Recent Documents Clear Recent Files List
.l._ml.l 1 testing. =ml _
EFEEE Apply and Exit iE
|
| |_|' "_T"l' Fewert
3 Sele
J Mew ~ —
-] 0 4
5 Open
- o Preview - B
H Save A, Start C ] E -
1043042014 () Connected
M| Saveps 1 () Disconnected
i = () Conkected
2 () Disconnected
-
=y Frint 4 ; () Connected
() Disconnected
: Preview s () Connected
() Disconnected
. () Conmected
() Disconnected
- () Conkected
15 () Disconnected
[4]4]w [¥] Sheett " B& 7 () Connected v
|4 | k| M| Sheetl Sheet2 1 € >
i FReady Spread

& Preview Only - Changes will not be saved,

When done with the Preview window, close it by clicking the X in the upper right.
For more information on printing a sheet, refer to Printing a Sheet from Spread Designer.

For more tasks in Spread Designer, return to Working with the Design.
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Printing a Sheet from Spread Designher

You can print a sheet from Spread Designer. You can also preview the print job before printing
the sheet. From the File menu icon, select Print and then Print Preview to see a window
with the page layout of a particular sheet (the latest selected sheet).

If you have already set up the printing and if you have used the Print Preview to see a preview
of the printing results, from the File menu icon, select Print to immediately send the sheet to
the printer. No dialog box appears. The Spread Designer uses your settings and prints to your
default printer.

If you want to set the printing settings, use the Page Setup Settings available from the menu
by selecting Page Layout. For more information, refer to the Sheet Print Settings Dialog.

For more information about printing in general, see Managing Printing (on-line
documentation) in the Developer’s Guide.

For more tasks in Spread Designer, return to Working with the Design.
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Designing Shapes

Each sheet can have its own drawing layer. For instance, in a spreadsheet you could create a
shape like a "star" or other graphic that could highlight data or point the user to some aspect of
working with the sheet. You could then proceed to customize aspects of that star or graphic
from size and background color to rotation angle or gradient. The shapes are available in code
(each shape being a separate class in the DrawingSpace namespace) or from the Insert and
Drawing Tools menus in the Spread Designer. You can use shapes to draw attention to parts
of your spreadsheet or emphasize some information or process involving the use of the
spreadsheet. For example, you can display a logo on your sheet, show a process with flowchart-
like graphics, or use shapes to simply highlight a particular result. There are several built-in
shapes for you to use on a sheet. Each shape can be rotated and resized, and their ability to be
rotated and resized by the end user can be constrained. When selected, the shape has resize
handles with which you can adjust the size and a rotate handle with which you can rotate the
shape. Colors, shadows, and transparency can be adjusted. Most users find it easy to create and
place the shapes using Spread Designer. You may also create and place shapes using code.

Shapes are a form of graphics that are drawn on a separate layer from that of the spreadsheet.
This drawing layer, or drawing space, is in front of the spreadsheet in the display. Shapes can be
made all or partially transparent to reveal the spreadsheet behind. An example of a multiple-
sided shape drawn in the space above a spreadsheet is shown in this figure to help you
understand the concept of layers. Because the shapes appear on this separate layer from the
sheet and can be thought to float above the spreadsheet, they are sometimes called floating
objects.

These topics can help you use shapes:

¢ Understanding the Built-in Shapes
¢ Customizing Particular Shapes
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e Customizing Text as a Shape
¢ Customizing a Polygon
e Customizing a Line as an Arrow
¢ Things To Do with Any Shape
e Adding a Shape to a Sheet
e Changing the Appearance of a Shape
e Rotating a Shape
¢ Resizing a Shape
e Rotating a Shape
e Adding a Drop Shadow
e Locking a Shape
e Using Keys with Shapes
¢ Advanced Topics for Shapes
¢ Creating a Custom Compound Shape
e Using Shapes with Maps
e Using Pictures in Shapes

For information on designing a shape, refer to the Insert Menu.

For information on shape keyboard navigation, refer to Default Keyboard Navigation (on-
line documentation) in the Developer’s Guide.

For information on creating camera shapes, refer to Creating Camera Shapes (on-line
documentation) in the Developer’s Guide.

For information on printing shapes, refer to Printing a Sheet with Shapes (on-line
documentation).

Understanding the Built-in Shapes

The FpSpread component provides the following built-in shapes that provide a basis for much
of the shape customization that is possible with the component. These shapes are available from
the Insert menu in the Spread Designer as well as from separate classes in code.

The shapes are summarized in this table (with arbitrarily colored examples of the shapes).

e Basic Shapes

e Arrow Shapes
¢ Balloon Shapes
¢ Special Shapes
e Star Shapes

To add a shape, you can use code or you can use the Spread Designer. For more information
about creating shapes in the Spread Designer, refer to the Insert Menu. For more information
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about the shapes classes, refer to the FarPoint.Win.Spread.DrawingSpace
('FarPoint.Win.Spread.DrawingSpace Namespace' in the on-line documentation)

namespace.
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Each shape can be rotated and resized, and their ability to be rotated and resized by the end
user can be constrained. Colors, shadows, and transparency can be adjusted.

Basic Shapes

The basic shapes are summarized in this table (with arbitrarily colored examples of the shapes).

Shape

EllipseShape ('EllipseShape Class' in the on-line
documentation)

LineShape ('LineShape Class' in the on-line
documentation)

MultiSideShape ("MultiSideShape Class' in the on-
line documentation)

RectangleShape ('RectangleShape Class' in the on-
line documentation)

RoundedRectangleShape
('RoundedRectangleShape Class' in the on-line
documentation)

TextShape ('TextShape Class' in the on-line
documentation)
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documentation)

TriangleShape ('TriangleShape Class' in the on-line i

Arrow Shapes
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Triangle

The arrow shapes are summarized in this table (with arbitrarily colored examples of the

shapes).

Shape

ArrowShape ('ArrowShape Class' in the on-
line documentation)

BentArrowShape ('BentArrowShape Class' in
the on-line documentation)

CalloutArrowShape ('CalloutArrowShape
Class' in the on-line documentation)

CurvedArrowShape ('CurvedArrowShape
Class' in the on-line documentation)

FourWayArrowShape ('"FourWayArrowShape
Class' in the on-line documentation)
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ThreeWayArrowShape

('ThreeWayArrowShape Class' in the on-line

documentation)

TwoWayArrowShape ("TwoWayArrowShape

Class' in the on-line documentation)

Balloon Shapes

<—>
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Arrow >
Three-
Way

Arrow >
Two-
Way

The balloon shapes are summarized in this table (with arbitrarily colored examples of the

shapes).

Shape

CaptionBalloonShape
('CaptionBalloonShape Class' in the on-line
documentation)

ExclamationBalloonShape
("ExclamationBalloonShape Class' in the on-
line documentation)

SquareCaptionBalloonShape
('SquareCaptionBalloonShape Class' in the
on-line documentation)

ThoughtBalloonShape
('"ThoughtBalloonShape Class' in the on-line
documentation)

Special Shapes
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The special shapes are summarized in this table (with arbitrarily colored examples of the
shapes).

Shape Example Insert
Menu
ArcShape ('ArcShape Class' in the on-line Special >
documentation) v Arc
BannerShape ('BannerShape Class' in the Special >
on-line documentation) [ﬁ Banner
CheckmarkShape ('CheckmarkShape Class' Special >
in the on-line documentation) % Checkmark
ChevronShape ('ChevronShape Class' in the — Special >
on-line documentation) > “"‘-h:-;_ Chevron
CrescentShape ('CrescentShape Class' in the Special >
on-line documentation) @ Crescent
DiamondShape ('DiamondShape Class' in Special >
the on-line documentation) <> Diamond
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DonutShape ('DonutShape Class' in the on- Special >
line documentation) Donut

HeartShape ('"HeartShape Class' in the on-
line documentation)

LightningBoltShape ('LightningBoltShape Special >
Class' in the on-line documentation) f Lightning
Bolt

UniversalNoShape ('UniversalNoShape Special >
Class' in the on-line documentation) ® Universal

Special >
Heart

S

No

XShape ('XShape Class' in the on-line 7 Special > X
documentation) ) q\
A N

—r

Star Shapes

The star shapes are summarized in this table (with arbitrarily colored examples of the shapes).

Shape Example Insert
Menu
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FivePointStarShape ('FivePointStarShape Class' Star >
in the on-line documentation) ff\ Five-

N Point
Star

BurstShape ('BurstShape Class' in the on-line Star >
documentation) {r:_,/;/l\% Burst

Customizing Particular Shapes

These topics describe how to customize particular shapes.

e Customizing Text as a Shape
¢ Customizing a Polygon
¢ Customizing a Line as an Arrow

Customizing Text as a Shape

The text shape is unique among the shapes that can be placed on a sheet. This shape allows you
to type in text that itself is treated as a shape. You can create a text shape in code or in the
Spread Designer.

Use the WordArt option in the Insert menu to create a text shape. Once a shape has been
created, the Drawing Tools menu can be used to set properties.

When you create a text shape in code, you must set a dimension (either Height or Width) after
setting the Text property. When the Text property is set, the size of the shape changes based on
the current font and text string settings. It then needs to be informed of the new size to which it
should be constrained. If a new Height or Width is not specified after setting the Text property,
the size of the shape created may be unpredictable (and may be so small as to be illegible).

When you create a text shape in the Spread Designer you can set several properties to customize
its appearance. When you first create a text shape, the Text Properties dialog is displayed as
shown here.
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@ Choose Font and Text
Select font:
bicrosoft Sans Serif w B I U
List font names in their font
Text:
Sample Text
Size: 825
k. Cancel

This includes the following items:

Text Settings Description and Reference

Font Select a font from the drop-down list of fonts available on your system
Text Type the text in the text block.
Size Set the size. This is not a property that is later editable.

To change the properties of the text shape, right click on the text (not the space in between the
text), and select Properties. The Shape Properties dialog is displayed. To change the fill
color of the text shape, select the BackColor property. (The ForeColor property is not the color
of the text shape itself.) To change the outline color of the text shape, select the OutlineColor
property. The font size cannot be set with this dialog; the size is determined by the size of the
overall shape. For more information about the Shape Properties dialog, refer to Shape
Properties Dialog.

You cannot the text to be only spaces; you must enter at least one non-space character.

For more details on the text shape in code, refer to the TextShape ('TextShape Class' in the
on-line documentation) class.
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Customizing a Polygon

The polygon (or multiple-sided shape) is unique among the shapes that can be placed on a
sheet. This shape allows you to specify any number of sides (above four). The Rectangle and
Triangle and Line shapes already cover the shapes with lower number sided shapes. You can
create a polygon in code or in the Spread Designer.

When you create a polygon in code, you must set the number of sides.

When you create a polygon in the Spread Designer you are asked the number of sides with the
dialog that is shown here.

Choose Mumber of Sides

Enter the number of zides for the palpgon [G to 285, incliszive).

Q. Cancel

The number of sides must be an integer.

For more details on the polygon in code, refer to the MultiSideShape ("MultiSideShape
Class' in the on-line documentation) class.

Customizing a Line as an Arrow

Besides an arrow shape, you can setup a line shape and change the ends to be arrow heads. You
can create an arrow from a line shape in code or in the Spread Designer.

When you create a line in the Spread Designer you can then set the start cap and end cap using
the shape properties as shown here. Create a shape in the designer using the Insert menu and
shape option, then right-click on the shape to set additional properties.

Copyright © GrapecCity, inc. All rights reserved.



Spread Windows Forms Spread Designer Guide

Shape Propernies
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The cap types are listed in this table, shown with a simulated image that roughly illustrates the

appearance.
Type of Cap Appearance

Flat

Square x’
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Round

Triangle

NoAnchor

SquareAnchor

RoundAnchor

DiamondAnchor

ArrowAnchor

LR
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AnchorMask

Custom User-defined.

For more details on the line shape in code, refer to the LineShape ('LineShape Class' in
the on-line documentation) class in the Assembly Reference.

Things To Do with Any Shape

These topics describe how to perform routine actions with any of the shapes.

¢ Adding a Shape to a Sheet

¢ Changing the Appearance of a Shape
¢ Rotating a Shape

¢ Resizing a Shape

e Moving a Shape

¢ Adding a Drop Shadow

¢ Locking a Shape

¢ Using Keys with Shapes

Adding a Shape to a Sheet

You can add a shape to a sheet in one of two ways, broadly speaking. These are using code or
using the Spread Designer interface.

One way is to add it programmatically, which is described in Working with Shapes in Code
(on-line documentation) in the Developer’s Guide.

Another way is to add it using the Insert menu, which is described in the Insert Menu and
specifically the Shape Properties dialog, which is described in Shape Properties Dialog.

You can add any number of shapes to a sheet and overlap them and adjust their appearance.
For more on customizing the shape, refer to Changing the Appearance of a Shape.

Changing the Appearance of a Shape

You can change several properties of a shape using the Spread Designer or code.

To change the appearance of a shape using the Spread Designer, refer to the Insert Menu and
the Shape Properties dialog in Shave Properties Dialoe.
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To change the appearance of a shape using code, set the properties of a shape object as
illustrated in this example. Refer to the FarPoint.Win.Spread.DrawingSpace
('FarPoint.Win.Spread.DrawingSpace Namespace' in the on-line documentation)
namespace and select the particular shape and define its properties using code. Here is an
example of an arrow shape with its outline color and background color being set. The example
also sets the size and placement of the shape with the SetBounds property.

Example

C#

// Add arrow shape with its outline color and background color set.
FarPoint.Win.Spread.DrawingSpace.ArrowShape arrow = new
FarPoint.Win.Spread.DrawingSpace.ArrowShape () ;

arrow.BackColor = Color.Plum;

arrow.ForeColor = Color.Pink;

arrow.3etBounds (0,0,200,100) ;
fpSpreadl.ActiveSheet.AddShape (arrow) ;

VB

‘' Add arrow shape with its outline color and background color set.
Dim arrow As New FarPoint.Win.Spread.DrawingSpace.ArrowShape ()
arrow.BackColor = Color.Plum

arrow.ForeColor = Color.Pink

arrow.SetBounds (0,0,200,100)

fpSpreadl.ActiveSheet.AddShape (arrow)

Rotating a Shape

You can rotate a shape.

To rotate a shape, in Spread Designer, select the shape and move the rotate handle (small green
dot) until the shape is rotated to the position you want. Click on the rotate handle at the top of
the shape and drag the cursor around the handle. The shape disappears temporarily leaving
only a dotted line until you unclick again.

Rotate handle at top

-
@ I of =elected shape
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Once you click on the rotate handle, the small green circle at the top of the selected item, drag
the pointer and immediately the display changes. Only a dotted line of the outline of the shape
is displayed and you can see the rotation of the shape. See the figure of the example shown here.

Cirag cursor around handle
LT to rotate shape

. ~————— Qutline of shape
. ; appears dotted
—— showing rotation

The cursor changes indicating that you are rotating the shape. When done rotating, let up on
the pointer and the shape is displayed in that rotated position.

If you rotate a shape by the rotate handle, it rotates by five degrees for every mouse move
message, which allows the rotation to move smooth and quickly. To rotate a shape by one
degree for each mouse move message, hold down the Ctrl key while rotating with the mouse.

You can allow the end user to rotate the shape or prevent them from doing so, using the
CanRotate property.

Resizing a Shape

You can resize a shape.

To resize a shape, in Spread Designer, select the shape and move the resize handles which
appear at the corners and sides of the shape. To resize the shape proportionately, select the
corner resize handles. Click to select the object. Then click the handle and drag it.

- -

As you drag a resize handle, the shape disappears temporarily and only the outline is displayed
as a dotted line. The cursor changes indicating that you are resizing the shape.
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When done resizing, let up on the pointer and the shape is displayed with the new size and
dimensions.

For a rounded rectangle, you can change the roundness of the ends by clicking and dragging on
the rounding handle (yellow square).

You can allow the end user to resize the shape or prevent them from doing so, using the CanSize
property.

Moving a Shape

You can move a shape.
To move a shape, in Spread Designer, select the shape and drag the shape to the new location.

You can allow the end user to move the shape or prevent them from doing so, using
the CanMove ('CanMove Property' in the on-line documentation) property.

Adding a Drop Shadow

You can add a drop shadow to a shape as shown in this figure for this rectangle shape.

From the Spread Designer, with the shape selected, from the Drawing Tools menu, click the
Drop Shadow option and select custom. The Shadow Properties dialog appears. The units
for the offset values are in pixels.

Locking a Shape

You can lock a shape and prevent the user from interacting with it. The shape remains visible
but cannot be moved, rotated, or changed.
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Locking a cell does not lock any shapes (floating objects) over that cell. A protected sheet only
means that all the cells in that sheet marked as locked are locked; it does not apply to shapes
over that sheet. To lock a shape, change the Locked property of that shape. In Spread Designer,
this can be done by right-clicking the shape and selecting Properties. This opens the Shape
Properties dialog. In this dialog, set the Locked property to true. In code, set the Locked
property for that shape to true. Lock each shape by setting the locked property on that
shape.Each shape can be locked individually.Locking means that the shape can not be selected
or interacted with.

For more information about locking cells on a sheet, refer to Locking a Cell (on-line
documentation).

Using Keys with Shapes

You can use the following keys on the keyboard to work with the shapes:

e arrow keys to move the shape in that direction
e Esc key to leave the shape and move focus to the cell
e Tab key to move the focus from shape to shape

Advanced Topics for Shapes

These topics describe some additional ways to work with shapes in Spread Designer.

Creating a Custom Compound Shape
Using Shapes with Maps

Using Pictures in Shapes

Creating Free-Hand Annotations

Creating a Custom Compound Shape

One of the inherent capabilities of all shape classes is the ability to have other shape objects
embedded in them. This is a great way of making compound shapes. This topic explains how to
create a custom compound shape that combines several built-in shapes and serves as a
watermark, which can identify information or corporate identity subtly (without obstructing or
obscuring the spreadsheet) as shown here. With this example, you can see how to create a
custom compound shape.
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To create this custom compound shape, define a custom shape class, called
CompanyWatermark, and set the properties to customize this appearance. This custom shape
combines several elements: a background gradient fades from a specified color to transparency;
an embedded shape contains an image of the company logo; a separate embedded text shape
spells the company name; and a text shape provides additional information such as Web site
address or company motto or security classification.

Deriving the Custom Class

Start by deriving a class from the standard RectangleShape class. This creates a rectangular
palette in which to place the embedded shapes. You could just as easily use other shapes such as
ellipses, or polygons, but your embedded shapes may be "clipped" (because embedded shapes
do not exceed the boundaries of the parent shape). Here is the code:

C#

public class CompanyWatermark
FarPoint.Win.Spread.DrawingSpace.RectangleShape

Visual Basic

Public Class CompanyWatermark
Inherits FarPoint.Win.Spread.DrawingSpace.RectangleShape

Setting Properties

Then create properties for accessing the internal shapes. One of the benefits of creating a
compound shape is that you can hide many of the unnecessary properties of the embedded
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shapes. You can expose, through custom properties, only the pertinent information. The first
property is the "CompanyColor" property. This is the main color in the background gradient,
which gradually fades to transparency in the main shape. It is also alpha-blended so as not to
fully obscure the sheet below. With the gradient class, other properties such as Style, which
determines the gradient direction and type of gradient, can also be set. This example uses a
Style of GradientStyle.TopDown.

The next property is an image property called "CompanyLogo". This property sets the graphic to
be displayed in the embedded logo shape. This example locks the logo shape to the upper left
corner of the watermark. You could very simply extend this with properties to allow alignment
of the logo.

Embedding Text Shapes

The most important part of the watermark is the company name. You can create this with an
embedded TextShape object to represent the company name. This has been exposed on the
watermark shape as the "CompanyName" property, which is a string. There are many
customizable features of the TextShape class that can be exposed such as Font or ForeColor,
though they are not exposed here. Also, for simplicity of this sample, the company name shape
is locked to be centered in the watermark shape.

And, finally, there is a secondary TextShape object that holds some additional text information
in the watermark. This could be a company motto, slogan, Web site address or even words like
"CONFIDENTIAL" or "Copyright 2005". Anchor this text to the bottom left corner of the
watermark shape for this example. Many additional properties can be set on this embedded
shape. This example only exposes items of interest. The text for this shape is exposed as the
"CompanyText" property.

Concluding Remarks

In the figure above, you see the full implementation of the CompanyWatermark class with the
other functions that were described. To create the pictured watermark, choose
"System.Drawing.Colors.SeaGreen" as the "CompanyColor", a custom bitmap as the
"CompanyLogo", "SunRay Finance" as the "CompanyName", and "CONFIDENTIAL" as the
"CompanyText".

Since Spread can scroll the viewport panes, override the TopChange and LeftChange events of
Spread to move the watermark with the current sheet so that it always appears across the top
and is as wide as the spreadsheet control. Also override the Top and Left properties of the
watermark class to move the embedded objects to be visible always within the watermark.

One of the features of the TextShape class is to stretch the text always to the dimensions of the
shape using the Font associated with it. This has been changed in the example with the
MeasureText method. The text string is measured using the control’s Graphics object and
current Font and then sets the TextShape dimensions accordingly. This guarantees that the
shape keeps the size locked to the specified font and font size.
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Using Shapes with Maps

You can set the keyboard actions to correspond with shape actions with maps. There is an input
map for shapes but it is available only with code, not with the Spread Designer.

For more information on action maps and input maps, refer to Managing Keyboard
Interaction (on-line documentation) of the Developers Guide and specifically the Default
Behavior for Shapes found in Default Keyboard Navigation (on-line documentation).

Using Pictures in Shapes

You can use pictures (images or graphics) in shapes:

e as background
¢ as foreground

After inserting a shape, you may right click on the shape to view its properties. There, you have
a complete list of editable options for the shape, including image background and image
foreground, which lets you import an image from elsewhere on your computer.

For more information about using pictures as background, refer to the description of the
Background Tab.

Creating Free-Hand Annotations

You can draw a free-hand shape in annotation mode.
Using Code
This example uses button controls to start and stop the drawing mode.

Example

C#

private void buttonl Click(object sender, EventArgs e)

{
fpSpreadl.StartAnnotationMode (true) ;

//fpSpreadl.StartAnnotationMode () ;
}

private void button2 Click(object sender, EventArgs e)

{
fpSpreadl.StopAnnotationMode () ;
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private void fpSpreadl AnnotationModeStarting(object sender,
FarPoint.Win.Spread.AnnotationModeEventArgs e)

{

e.DrawingSurface.ForeColor = Color.BlueViolet;
e.DrawingSurface.BackColor = Color.Thistle;

private void fpSpreadl AnnotationModeEnding (object sender,
FarPoint.Win.Spread.AnnotationModeEventArgs e)

{
listBoxl.Items.Add ("Stop Drawing");

VB

Private Sub Buttonl Click(ByVal sender As System.Object, ByVal e As
System.EventArgs) Handles Buttonl.Click
FpSpreadl.StartAnnotationMode (True)
'FpSpreadl.StartAnnotationMode ()
End Sub

Private Sub Button2Z Click(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles Button2.Click
FpSpreadl.StopAnnotationMode ()
End Sub

Private Sub FpSpreadl AnnotationModeStarting(ByVal sender As
System.Object, ByVal e As
FarPoint.Win.Spread.AnnotationModeEventArgs) Handles
FpSpreadl .AnnotationModeStarting

e.DrawingSurface.ForeColor = Color.BlueViolet
e.DrawingSurface.BackColor Color.Thistle

End Sub

Private Sub FpSpreadl AnnotationModeEnding (ByVal sender As
System.Object, ByVal e As
FarPoint.Win.Spread.AnnotationModeEventArgs) Handles
FpSpreadl.AnnotationModeEnding

ListBoxl.Items.Add ("Stop Drawing")

End Sub
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2 Index

adding

drop shadow, 136
caption balloon shape, 12-13
Designer Guide

FarPoint Spread for Windows Forms, 0
end cap, 130-133
mode

Block (see Operation Mode), 76-78
resizing

AutoFit in Designer, 110-111, 108-110
styles

default style editor, 82-84
toolbars

displaying, 29
2-way arrow shape, 12-13
3-way arrow shape, 12-13
4-way arrow shape, 12-13
adding

columns (in Designer), 68-69

rows (in Designer), 68-69
Adding a Drop Shadow, 136
Adding a Shape to a Sheet, 133
Adding and Customizing Sheets, 116
Advanced Topics for Shapes, 137
alpha blending, 30

shape shadow, 69-70, 70-71
Alternating Row Collection Editor, 80-81
Applying the Design to the Form, 117
arc shape, 12-13
Arrow Shapes, 124-125

four-way, 12-13

three-way, 12-13
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two-way, 12-13
arrows
arrow heads, 130-133
as line, 130-133
bent arrow shape, 12-13
callout shape, 12-13
curved arrow shape, 12-13
shapes, 12-13
straight arrow shape, 12-13
AutoFit, 110-111, 108-110
Background Tab, 45-46
Cell Type dialog, 34-37
Balloon Shapes, 125
caption, 12-13
exclamation, 12-13
square caption, 12-13
thought, 12-13
banner shape, 12-13
BarCode Tab, 37-38
Basic Shapes, 123-124
bent arrow shape, 12-13
Block Mode (see Operation Mode), 76-78
bolt (lightning) shape, 12-13
Border Editor, 81-82
built-in
shapes, 12-13
burst shape, 12-13
Button Tab, 38-39
callout arrow shape, 12-13
caps
end of arrow, 130-133
start of arrow, 130-133

caption balloon shape, 12-13
Cell Type Dialog, 34-37
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Cell Types Toolbar, 29, 29
cells
property editor, 82-84
Cells, Columns, and Rows Editor, 82-84
Cells, Columns, and Rows Editor dialog, 82-84
celltype
GcDateTime, 46-47
GcTextBox, 47-48
Changing the Appearance of a Shape, 133-134
Check Box Tab, 39-40
checkmark shape, 12-13
chevron shape, 12-13
Color Picker Tab, 40-41
colors
shape shadow, 69-70, 70-71
Column Width dialog, 67-68
columns
property editor, 82-84
Columns Editor, 82-84
Combo Box Tab, 41-42
compound shapes, 137-139
Conditional Formatting Dialog, 63-64
Creating a Custom Compound Shape, 137-139
Creating Free-Hand Annotations, 140-141
crescent shape, 12-13
Ctrl key
rotating shapes, 134-135
Currency Tab, 42-43
curved arrow shape, 12-13
custom
drop shadow, 70-71, 136
file delimiters, 64-65
shapes, 137-139
Custom File Options Dialog, 64-65

Copyright © GrapecCity, inc. All rights reserved.

144



Spread Windows Forms Spread Designer Guide 145

custom name, 65-67

dialog, 65-67
Customizing a Line as an Arrow, 130-133
Customizing a Polygon, 129-130
Customizing Particular Shapes, 128
Customizing Text as a Shape, 128-129
Data Menu, 22-23
Date-Time Tab, 43-44
defaultgroupfooter, 84-85
DefaultGroupFooter Editor, 84-85
degrees rotated, 134-135
delimiters

custom file, 64-65

setting in Designer, 64-65
designer

files, 15-18

GcDateTime, 46-47

GcTextBox, 47-48

printing, 15-18
Designer (See Spread Designer), 7
designing

shapes, 30
Designing in the Data Area, 99
Designing Shapes, 121-122
dialog boxes

Spread Designer, 34
dialogs

Border Editor, 81-82

Cell Type, 34-37

Cells Editor, 82-84

Column Width, 67-68

Custom File Options, 64-65

Focus Indicator Editor, 86-87

Go To Cell, 65
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Header Editor, 88-90
Row Height, 67-68
Shadow Properties, 70-71, 136
Shapes Properties, 30
Sheet Print Settings, 73-75
Sheet Settings, 71-73
SheetSkin Editor, 91-92, 92-93
Sort, 75-76
Spread Settings, 76-78
Unhide Specific Column, 78
Unhide Specific Row, 78
Zoom, 78-79
diamond shape, 12-13
directions
of drop shadow, 70-71
donut shape, 12-13
Draw menu, 30
drawing
Draw menu, 30
objects (shapes), 12-13
toolbar, 30
drawing space
defined, 121-122
Drawing Toolbar, 30, 29
drop shadow, 136
shapes, 70-71
editor
chart, 95-96
defaultgroupfooter, 84-85
GceDateTime, 93-94
GcTextBox, 93-94
input map, 90
smartprint, 94-95

editors
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Border, 81-82
cells, 82-84
Focus Indicator, 86-87, 23-25
Header, 88-90
hyperlink collection, 48-49
named styles, 90-91
SheetSkin, 91-92, 92-93
Spread Designer, 80
ellipse shape, 12-13
embedded
shapes, 137-139
Entering a Formula in Spread Designer, 115-116
exclamation balloon shape, 12-13
executable
Spread Designer, 11-12
file
preferences, 15-18, 29
File Menu, 15-18
file options
setting in Designer, 64-65
files
custom delimiters, 64-65
printing, 15-18
recently opened, 15-18
saving, 15-18
Spread Designer, 118
five-point star shape, 12-13
floating objects (shapes), 12-13, 121-122
Focus Indicator Editor, 86-87
Focus Indicator Edtior, 23-25
fonts
text shape, 128-129
Formatting Toolbar, 30, 29
Formula Bar, 30, 85-86, 115-116
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Formula Editor, 85-86
four-way arrow shape, 12-13
GcDateTime Tab, 46-47
GcTextBox Tab, 47-48
General Tab, 44-45

Cell Type dialog, 34-37
General Toolbar, 29, 29
Getting Started Designing, 8-9
go to

Designer, 65

cell in Designer, 18-19
Go To Cell, 18-19
Go To Cell Dialog, 65
graphical objects (shapes), 12-13
graphics

Draw menu, 30
green dot (rotate handle), 134-135
Grouplnfo Collection Editor, 87-88
Guides

Spread Designer, 0
handle

rotate shape, 134-135

rounding rectangle, 135-136
Header Editor, 88-90
heart shape, 12-13
Help Menu, 25
hexagon

shapes, 129-130
hiding

toolbars, 29
Home Menu, 18-19
Hyperlink Collection Editor, 48-49
Hyperlink Tab, 48-49
Image Tab, 49-50
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InputMap Editor, 90
Insert Columns dialog, 68-69
Insert Menu, 19-22
Insert Rows dialog, 68-69
inserting

columns (in Designer), 68-69

rows (in Designer), 68-69
Introduction to Spread Designer, 7
Label Tab, 50-51
layers

drawing space, 121-122
lightning bolt shape, 12-13
line shape, 12-13
lines

as arrow, 130-133

shapes, 130-133
link area

Designer, 48-49
links

Designer, 48-49
ListBox Tab, 51-52
locking

shapes, 136-137
Locking a Shape, 136-137
Mask Tab, 52-53
moving

shapes, 136
Moving a Shape, 136
MultiColumnComboBox Tab, 53-54
MultiOption Tab, 54-55
multiple

sided shape, 12-13
multiple-sided shape, 12-13
multiple-sided shapes, 129-130
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Name Manager Dialog, 65-67
Named Style Editor, 90-91
named styles

editor, 90-91
no symbol shape, 12-13
Number Tab, 56
octagon

shapes, 129-130
offset

shape shadow, 70-71
opening

recent files, 15-18
oval (see ellipse shape), 12-13
Overview of Spread Designer Features, 7-8
overviews

Spread Designer, 14-15
Page Layout Menu, 22
pentagon

shapes, 129-130
Percent Tab, 56-57
polygon

shape, 129-130
polygon shape (see multiside shape), 12-13
pre-defined

shapes, 12-13
preferences

file options, 15-18

Spread Designer, 29
preview

shapes, 69-70
Preview window, 119
previewing

changes with Spread Designer, 119

printing with Spread Designer, 119-120
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Previewing a Sheet in Spread Designer, 119
print preview, 119-120
printing
design, 15-18
print preview, 119-120
with Spread Designer, 119-120
Printing a Sheet from Spread Designer, 119-120
Progress Tab, 58
properties
Shadow Properties dialog, 70-71, 136
Shapes Properties dialog, 30
protecting
shapes, 136-137
ratio
tab strip, 31-32
recent files, 15-18
rectangle shape, 12-13
rectangles
rounded, 12-13
Regular Expression Tab, 59-60
reset all settings in the Spread Designer, 117-118
resetting
in Spread Designer, 117-118
Resetting and Clearing Design Work, 117-118
resizing
shapes, 135-136
Resizing a Shape, 135-136
Rich Text Tab, 60-61
rotate handle, 134-135
rotating
shapes, 134-135
Rotating a Shape, 134-135
rounded rectangles, 12-13
rounding handle, 135-136
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Row Height dialog, 67-68
Row Height or Column Width Dialog, 67-68
Row or Column Insert or Delete Dialogs, 68-69
rows

property editor, 82-84
Rows Editor, 82-84
rule, 94-95
rules

color, 63-64

conditional formatting, 63-64

data bar, 63-64

highlight, 63-64

icon, 63-64

manager, 63-64
running

Spread Designer stand alone, 11-12
Running Spread Designer Stand Alone, 11-12
saving

files, 15-18
Saving and Opening Design Files, 118
Saving Spread Designer to an XML file, 118
scaling

display, 78-79
scroll bars

Designer settings, 76-78
Selecting a Column of Cells, 103-104
Selecting a Contiguous Range of Cells, 101-102
Selecting a Row of Cells, 102-103
Selecting a Sheet of Cells, 104-106
Selecting an Entire FpSpread Component, 106
Selecting an Individual Cell, 100
Selecting an Item in the Spread Designer, 99-100
Selecting the Cells with Data, 100-101

selections
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Spread Designer, 99-100
setting

delimiters, 64-65
Setting Cell Properties in Spread Designer, 111-113
Setting Column Properties in Spread Designer, 110-111
Setting Properties in Spread Designer, 106
Setting Row Properties in Spread Designer, 108-110
Setting Sheet Properties in Spread Designer, 107-108
Setting Table Properties in Spread Designer, 113-115
Settings Menu, 23-25
Shadow Properties dialog, 70-71, 136
shadows

alpha blending, 69-70, 70-71

color, 69-70, 70-71

direction, 70-71

offset, 70-71

properties, 70-71, 136

shapes, 70-71, 136
Shape Properties Dialog, 69-70
Shape Shadow Properties Dialog, 70-71
shapes

arc, 12-13

arrow, 12-13

banner, 12-13

bent arrow, 12-13

burst, 12-13

callout arrrow, 12-13

caption balloon, 12-13

checkmark, 12-13

chevron, 12-13

compound, 137-139

crescent, 12-13

curved arrow, 12-13

custom, 137-139
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Designer drawing toolbar, 30
designing, 30

diamond, 12-13

donut, 12-13

Draw menu, 30

drop shadow, 136

ellipse, 12-13

exclamation balloon, 12-13
five-point star, 12-13
floating objects, 121-122
four-way arrow, 12-13

heart, 12-13

lightning bolt, 12-13

line, 12-13

locking, 136-137

moving, 136

multiple-sided, 129-130
multiside, 12-13

no symbol, 12-13

overview, 121-122

polygon, 129-130

preview, 69-70

rectangle, 12-13

resizing, 135-136

rotating, 134-135

shadow alpha blending, 69-70, 70-71
shadow color, 69-70, 70-71
shadow direction, 70-71
shadow offset, 70-71
Shadow Properties dialog, 70-71, 136
Shapes Properties dialog, 30
square caption balloon, 12-13
text, 128-129, 12-13
thought balloon, 12-13
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three-way arrow, 12-13

triangle, 12-13

two-way arrow, 12-13

types, 12-13

universal NO symbol, 12-13

X, 12-13
Shapes Properties dialog, 30
Sheet Context Menu, 25
Sheet Print Settings Dialog, 73-75
Sheet Settings Dialog, 71-73
SheetSkin Editor, 91-92, 92-93
SheetView Collection Editor, 92-93
Shortcut Collection Editor, 93-94
shortcutkey, 93-94
Simple Example Using Spread Designer, 9-11
sizes

text shape, 128-129
skins

editor, 91-92, 92-93
Slider Tab, 61-62
SmartPrintRule Collection Editor, 94-95
Sort Dialog, 75-76
sorting

Sort dialog in Designer, 75-76
Special Shapes, 125-127
split box, 76-78
split boxes

settings, 76-78
Spread Designer, 0, 7

about, 14-15

applying changes, 117

AutoFit option, 110-111, 108-110

Border Editor, 81-82

Cell Type dialog, 34-37
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Cells Editor, 82-84

clearing data, 117-118

closing, 117

Column Width dialog, 67-68
Custom File Options dialog, 64-65
default settings, 31-32

design mode, 31-32

dialog boxes, 34

drawing toolbar, 30

editors, 80

executable, 11-12

exiting, 117

Focus Indicator Editor, 86-87
formula bar, 30, 85-86, 115-116
Header Editor, 88-90

Insert Columns dialog, 68-69
Insert Rows dialog, 68-69
interface, 14-15

introduction, 7

menus, 15

opening, 8

opening file, 118

overview, 14-15

parts, 14-15

property list, 31-32

resetting, 117-118

Row Height dialog, 67-68
saving file, 118

selections, 99-100

Sheet Print Settings dialog, 73-75
Sheet Settings dialog, 71-73
SheetSkin Editor, 91-92, 92-93
Sort dialog, 75-76

Spread Settings dialog, 76-78
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stand-alone application, 11-12

starting, 8

status bar, 32-33

toolbar, 29

user interface, 14-15

verb, 8

working with, 99

Zoom dialog, 78-79
Spread Designer Data Area, 30-31
Spread Designer Dialogs, 34
Spread Designer Editors, 80
Spread Designer Guide, 0

FarPoint Spread for Windows Forms, o
Spread Designer in stand alone mode, 8
Spread Designer Menus, 15
Spread Designer Property Window, 31-32
Spread Designer Status Bar, 32-33
Spread Designer Toolbars, 29
Spread Designer User Interface, 14-15
Spread Settings Dialog, 76-78
SpreadChart Collection Editor, 95-96
SpreadSkin Editor, 96-97
square caption balloon shape, 12-13
stand-alone mode

Spread Designer, 11-12
star shape

five-point star, 12-13
Star Shapes, 127-128
start cap, 130-133
Starting Spread Designer, 8
styles

editor in Designer, 90-91
tab strip bar

using, 31-32
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tab strip ratio

using bar, 31-32
Table Context Menu, 25-29
TabStrip Editor, 97-98
text

shape, 128-129
text shape, 12-13
Text Tab, 62-63
Things To Do with Any Shape, 133
thought balloon shape, 12-13
three-way arrow shape, 12-13
toolbars

Cell Types, 29

Drawing, 30, 29

Formatting, 29

General, 29

hiding, 29

Spread Designer, 29
triangle shape, 12-13
two-way arrow shape, 12-13
types

of shapes, 12-13
Understanding the Built-in Shapes, 12-13
Unbhide Specific Column dialog, 78
Unhide Specific Row dialog, 78
Unhide Specific Row or Column Dialogs, 78
universal no symbol shape, 12-13
Using Keys with Shapes, 137
Using Pictures in Shapes, 140
Using Shapes with Maps, 139-140
verbs

Spread Designer, 8
View Menu, 23

watermark
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shapes, 137-139
Ways to add a shape to a sheet, 133
Working with the Design, 117
X shape, 12-13
yellow square (rounding handle), 135-136
Zoom Dialog, 78-79

zooming

display, 78-79
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